"Failed - Forbidden" while downloading

So… I’ve downloaded Shotcut before and it went all good, but now I’m trying to download it back again, and it just won’t and responds with “Failed - Forbidden” and I’m not sure why this is happening… I cancelled it and decided to attempt on downloading it again, but it still responded the same way… What should I do to resolve this issue?

Did you try from this page?

That happened to me on the latest version of SC. It was Avast anti-virus that caused it for me. Disabling Avast for 10 minutes and installing whilst it was disabled solved in my case. Maybe temporarily disabling your own security software will do the same for you.

Yup… Been using that link the whole time.

Which installer, and from which hub?

64-bit Windows Installer (Tried the 32 bit one already) and by the GitHub

This is usually reported with slow downloads from Site 1 via Github because an S3 download token expires after 5 minutes. I do not know why they have it so restricted for public files! That is why Site 2 via FossHub is offered. If one does not work, try the other - that is why two sites are offered.

Thanks for the feedback. I’ll be sure to try it by Fosshub. I haven’t even thought of downloading it from Fosshub. I didn’t know why there would be 2 separate sites.

Oftentimes Antivirus softwares just straight up block some of the sites and also restrict the incoming or outgoing connections. Almost 80% of the times, it just works if you disable the antivirus straight-up.Till those sites are blocked, https://4hub.net can be an awesome alternative for entertainment.