Fail to open webcam/mic error OSX

I try to use the Voiceover / Webcam feature and followed the tutorial,
however it does not work. I get a very brief error message, and I found it
in the Application Log:

[Debug ] AvfoundationProducerWidget::newProducer “avfoundation:USB Camera:Samson C01U Pro Mic?pixel_format=yuyv422&framerate=30&video_size=1280x720”
[Info ] MainWindow::showStatusMessage “Failed to open avfoundation:USB Camera:Samson C01U Pro Mic”

I use a Samson Mic and a Logitec Webcam
I do not understand why it does not show the logitec camera
both are connected via usb and work fine outside Shotcut.

OSX 10.13.4 ShotCut 18.05.03

I figured out this broke in v17.05. Thanks, I will take a look at it. Was planning to anyways as part of FFmpeg upgrade.

For some reason, it succeeds for me if I run it from the command line /Applications/
This makes it difficult to debug. :frowning: but it may be a workaround.

thank you. I confirm it records voice and sound when starting from the command line.
The video is not displayed during the recording. is this correct? Audio and Video is recorded well (from separate devices), but not displayed during the recording.

It is normal that video is not displayed after you start capturing in Export.

This issue was fixed in v18.06 for macOS.

Still having problems with the webcam in MacOS 10.11.6 running SC 18.11.18


It works for me on macOS 10.13. FFmpeg libavdevice probably no longer works with that older version of OS X.

Also tried on another mac running 10.12.4 and same thing, so you could well be right about libavdevice not supporting those versions of OS.

I am having this same problem with macOS 10.14.3 and Shotcut 19.02.28.

Both the builtin camera on a MacBook Pro and an external USB webcam (Logitech C920) work for me using Shotcut v19.02.28 on macOS 10.14.3. If it does not work, you should try to debug it and submit a patch.

Also, both the builtin (FaceTime HD) and the Logitech USB webcam work for me on a newer MacBook Pro running macOS 10.13.6.

Thank you for making always great progress!!!

I happend to try again by opening Shotcut directly or via the terminal. In both cases my camera is not connected.

Mac Mini M1, 2020 Silicon, OS 12.2 16GB
Shotcut 20.01.30 ARM

Camlink HDMI to USB3 adapter fails to open.

I copied the last part of the Application log.

[Debug ] AvfoundationProducerWidget::newProducer “avfoundation:Cam Link:Cam Link?pixel_format=yuyv422&framerate=30&video_size=1280x720”
[Info ] MainWindow::showStatusMessage “Failed to open avfoundation:Cam Link:Cam Link”
[Debug ] VideoVectorScopeWidget::profileChanged 709

Sometimes macOS seems to have trouble managing its Entitlements, which are now required. I face this sometimes, and macOS will not ask me to give Shotcut permission to the microphone and camera and instead crash. I have not figured out how to reset it at the OS level. I can inspect the .app with the codesign tool to verify the entitlements are declared. And I can install the app on another machine, and it prompts me and works. Also, I have not found a way to prevent a crash. In a debugger it works and has the entitlements. If I deny the debugger tool, terminal, and Shotcut apps in System Preferences > Security & Preferences it does not crash and properly shows an error in the message status area. Go figure. Only thing I have figured out so far is that this problem might be related to having more than one copy of an app.

Update: Now on the machine where it was crashing with the 22.03 beta it works - just a few minutes after writing this response. In the course of testing and writing this, I had toggled off Shotcut in System Preferences, closed my development/debugging tool, and toggled Shotcut back in System Preferences. Like I said, sometimes macOS has trouble managing its entitlements, and we are at its mercy.

Why doesn’t my Logitech webcam show up in Shotcut when using the Voiceover / Webcam feature, even though both my Samson Mic and Logitech Webcam are connected via USB and work fine outside of Shotcut?