Fail to make proxies

What is your operating system?[code]
System: Host: Kernel: 5.8.0-3-amd64 x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/vmlinuz-5.8.0-3-amd64 root=/dev/mapper/VGKubuntu2020-LVKub2020 ro quiet
video=1280x1024 splash init=/lib/systemd/systemd
Desktop: KDE Plasma 5.14.5 wm: kwin_x11 dm: SDDM Distro: MX-19.4_KDE_x64 patito feo November 11 2020
base: Debian GNU/Linux 10 (buster)
Machine: Type: Desktop System: MSI product: MS-7693 v: 4.0 serial:
Mobo: MSI model: 970 GAMING (MS-7693) v: 4.0 serial: BIOS: American Megatrends v: 22.4
date: 12/21/2015

CPU: Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 2
stepping: N/A microcode: 6000852 L2 cache: 2048 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 49198
Speed: 4099 MHz min/max: N/A Core speeds (MHz): 1: 4099 2: 4099 3: 4099 4: 4098 5: 4099 6: 4099
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 450.80.02 bus ID: 01:00.0
chip ID: 10de:1c03
Display: x11 server: X.Org 1.20.10 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
compositor: kwin_x11 resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 00:14.2 chip ID: 1002:4383
Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:10f1
Sound Server: ALSA v: k5.8.0-3-amd64

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
I reinstalled 21.03.21 apimage after the previous install just woudn’t startup.

Can you repeat the problem? If so, what are the steps?
After hitting F4 to make proxies they all fail.
ffmpeg version n4.2.4-7-gc9f3835b2b Copyright (c) 2000-2020 the FFmpeg developers
built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)
configuration: --prefix=/root/shotcut/Shotcut/ --disable-static --disable-doc --enable-gpl --enable-version3 --enable-shared --enable-runtime-cpudetect --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libvpx --enable-libopus --enable-libzimg --enable-libdav1d --enable-libaom --disable-decoder=libaom_av1 --enable-libjack --enable-libxcb --enable-libpulse
libavutil 56. 31.100 / 56. 31.100
libavcodec 58. 54.100 / 58. 54.100
libavformat 58. 29.100 / 58. 29.100
libavdevice 58. 8.100 / 58. 8.100
libavfilter 7. 57.100 / 7. 57.100
libswscale 5. 5.100 / 5. 5.100
libswresample 3. 5.100 / 3. 5.100
libpostproc 55. 5.100 / 55. 5.100

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from ‘/home/reece/Videos/100GOPRO/MU Grantville/GX010416.MP4’:
major_brand : mp41
minor_version : 538120216
compatible_brands: mp41
creation_time : 2021-07-11T10:04:12.000000Z
firmware : HD8.
Duration: 00:11:47.01, start: 0.000000, bitrate: 45266 kb/s
Stream #0:0(eng): Video: hevc (Main), 1 reference frame (hvc1 / 0x31637668), yuvj420p(pc, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 45001 kb/s, 50 fps, 50 tbr, 90k tbn, 50 tbc (default)
creation_time : 2021-07-11T10:04:12.000000Z
handler_name : GoPro H.265
encoder : GoPro H.265 encoder
timecode : 10:04:12:48
Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 189 kb/s (default)
creation_time : 2021-07-11T10:04:12.000000Z
handler_name : GoPro AAC
timecode : 10:04:12:48
Stream #0:2(eng): Data: none (tmcd / 0x64636D74) (default)
creation_time : 2021-07-11T10:04:12.000000Z
handler_name : GoPro TCD
timecode : 10:04:12:48
Stream #0:3(eng): Data: bin_data (gpmd / 0x646D7067), 50 kb/s (default)
creation_time : 2021-07-11T10:04:12.000000Z
handler_name : GoPro MET
Stream #0:4(eng): Data: none (fdsc / 0x63736466), 12 kb/s (default)
creation_time : 2021-07-11T10:04:12.000000Z
handler_name : GoPro SOS
Stream mapping:
Stream #0:0#0:0 (hevc (native) → hevc (hevc_nvenc))
Stream #0:1#0:1 (aac (native) → ac3 (native))
Press [q] to stop, [?] for help
[graph_1_in_0_1 @ 0x55a55d431cc0] tb:1/48000 samplefmt:fltp samplerate:48000 chlayout:0x3
[Parsed_scale_1 @ 0x55a55dde4dc0] w:-2 h:540 flags:‘bicubic’ interl:0
[graph 0 input from stream 0:0 @ 0x55a55dde5e40] w:1920 h:1080 pixfmt:yuvj420p tb:1/90000 fr:50/1 sar:1/1 sws_param:flags=2
[swscaler @ 0x55a55ddeb080] deprecated pixel format used, make sure you did set range correctly
[Parsed_scale_1 @ 0x55a55dde4dc0] w:1920 h:1080 fmt:yuvj420p sar:1/1 → w:960 h:540 fmt:yuv420p sar:1/1 flags:0x4
[hevc_nvenc @ 0x55a55d40cc00] Loaded Nvenc version 10.0
[hevc_nvenc @ 0x55a55d40cc00] Nvenc initialized successfully
[hevc_nvenc @ 0x55a55d40cc00] dl_fn->cuda_dl->cuInit(0) failed → CUDA_ERROR_UNKNOWN: unknown error
[hevc_nvenc @ 0x55a55d40cc00] Nvenc unloaded
Error initializing output stream 0:0 – Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
[AVIOContext @ 0x55a55d421f00] Statistics: 0 seeks, 0 writeouts
[AVIOContext @ 0x55a55d3eec00] Statistics: 1688240 bytes read, 4 seeks
Conversion failed!
Failed with exit code 1

[hevc_nvenc @ 0x55a55d40cc00] dl_fn->cuda_dl->cuInit(0) failed → CUDA_ERROR_UNKNOWN: unknown error

I do not think this is a bug. NVENC is not working on your machine for this for some reason, and you need to turn off Settings > Proxy > Use Hardware Encoder. You may also want to try a reboot or installing a different driver version. The above line means there is some nvidia driver-related problem. For example, the following bug thread suggests a version mismatch between the driver and kernel version:

Thanks for that advice. I did just turn off hardware encoder and proxie jobs are working. Thinking back I recall turning it on after some time use with it off. I don’t know why I thought setting hardware encode would be better/faster. I posted my query here not because I considered it a bug but because of the areas I could post it up I thought this might have been the best place for a helpful answer and it has.