Fail to convert a video without sound


#1

Hi. I am new to Shotcut and also to video editing.

I have a video that has no sound. When I dragged it into Shotcut, it said it is good to convert the video format because of the frame rate. I tried to use ‘very good’ and ‘best’ to convert it, but both failed. Though I can normally convert videos that have sound. The error log was

ffmpeg version n4.1.3-4-g7c2dd1f Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 5.5.0 (GCC)
  configuration: --prefix=/root/shotcut/shotcut/Shotcut --disable-static --disable-doc --enable-gpl --enable-version3 --enable-shared --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libvpx --enable-libopus --enable-libmfx --cross-prefix=x86_64-w64-mingw32.shared- --arch=x86_64 --target-os=mingw32 --pkg-config=pkg-config
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
[h264 @ 0000000000e14480] Reinit context to 2160x1088, pix_fmt: yuv420p
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'D:/path-to-the-file/2019_05_12_14_57_17.mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: isommp42
    creation_time   : 2019-05-12T06:58:35.000000Z
    com.android.version: 9
  Duration: 00:01:18.33, start: 0.000000, bitrate: 15985 kb/s
    Stream #0:0(eng): Video: h264 (High), 1 reference frame (avc1 / 0x31637661), yuv420p(tv, smpte170m/bt470bg/smpte170m, left), 2160x1080 (2160x1088), 15981 kb/s, SAR 1:1 DAR 2:1, 31.28 fps, 90k tbr, 90k tbn, 180k tbc (default)
    Metadata:
      creation_time   : 2019-05-12T06:58:35.000000Z
      handler_name    : VideoHandle
Stream map '0:a' matches no streams.
To ignore this, add a trailing '?' to the map.
[AVIOContext @ 0000000000f18bc0] Statistics: 195781 bytes read, 2 seeks
Failed with exit code 1

My Shotcut version is 19.04.30 on Windows 10.


#2

Thanks for your report. This issue is fixed for the next release: