Fade to transparent (and other opacity filters) suddenly stopped working after I updated

So I was literally just reading other threads about how to make a fade to transparent, just a simple image, add fade out and check the opacity option, it worked, then before exporting I saw there was an update. As I did it pretty quickly I just closed it and updated Shotcut, did the exact same steps as before but now it isn’t working, in fact any opacity filter isn’t showing. In the video you can see the fade out to transparent, in the last few frames the image goes weird and then total black. I’m really confused as to what happened because I repeated the same steps that worked before but now they didn’t. Tried it with a solid color instead and same thing happens, the image stays the color and in the last couple of frames it changes a bit and then jumps to full black.

What happens if the opacity box is unchecked for any fades on the V1 track?

@Austin is right
The Adjust opacity instead of fade with black should be unchecked in fades on track V1

Wait, but isn’t that just fade to black? Or is it detecting the transparent layer on top and making in fade to transparent automatically?

It fades to black because there is nothing under track V1
In Shotcut, transparency over emptiness is not represented by those checkered things we see in other programs.

I just tried it and it does fade to black, same as your example, image layer in V1 and transparent layer in V2 with the box unchecked. Hmm then, I don’t understand, how can I export this in png sequence with the fade to transparency?
Sorry, I haven’t used Shotcut that much, I swear in the previous version when I tried it it did fade to transparency with the box checked

Okay so, after exporting various batches I can confirm that it was fine the first time, with the Adjust opacity instead of fade with black checked, it just looks glitchy inside Shotcut. But after exporting it the PNGs do have transparency. I guess the Shotcut viewer can’t process the transition to transparency correctly or something, it was too confusing.

How does one see transparency? One way as @MusicalBox mentioned above is to blend with some hidden background like the checkerboard pattern. Having to always blend V1 with something would reduce performance when that is rarely needed. However, you can choose to do something like that yourself by selecting Output in the top left hand corner and adding the Alpha Channel: View video filter. You can set Display to different things including Checkered Background. Just make sure you disable this filter before you export, or it will export exactly what you are viewing.


This topic was automatically closed after 90 days. New replies are no longer allowed.