Fade out not working after moving clip and extending left side

What is your operating system?
Linux

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.06.23

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

  1. Add clip with fade out video filter.
  2. Then video fade out filter works fully ok.
  3. Move clip and next change its lenght but NOT by catching right side but by catching left side.
  4. Video fade out filter behaves like not existing (there is no fade out effect).

If after one execution of 3rd step fade out video still works ok, repeat step 3 few times. I’m not 100% sure but I have impression that rather shortening clip lenght causes that, then extending its lenght. I have also impression that the problem is both work for jpg and png but most of my images are png.

As result some clips in final video doesn’t have expected fade out effect. It’s a bit irritating as it does concern not all clips but “random” ones (even if of course it’s not random but those where changing lenght was done in specific way).

1 Like

Can reproduce on Windows 10, Shotcut versions 22.06.23 & Beta 22.09.01
Simplest steps to reproduce

  1. Open color clip, any color. (Longer than 2 seconds)
  2. Place on Timeline
  3. Apply Fade Out Video (Default 1 second)
  4. Trim video length from the left side of the clip by at least 1 second.

firefox_2022-09-06_08-29-48

Workaround:
Copy, remove, and paste the filter.

1 Like

One thing I can notice as difference between Windows and Linux is that triming by left side on Windows is very easy and smooth and on Linux sometimes I have to “fight a lot” to trim it by left side. Not sure if it’s by design or if it’s sth wrong with trimming on left side by itself. Sometimes shutcut doesn’t want to start moving clip border on Linux.

I have snapping turned off.

1 Like

Thanks for the excellent report. This is fixed for the next release.

3 Likes

This fix broke more common things. Thus, I have reverted and not fixed in the next release 22.09