Fade In and Fade Out filters. Adjust opacity instead of fade with black

I don’t know which option is more preferred, but I think the “Adjust opacity instead of fade with black” option should be selected by default.
Fade

1 Like

I would also prefer it to be selected by default.

I doubt that the default will be changed.
You can set both filters to default to Adjust Opacity.
The filters are here.
\Shotcut\share\shotcut\qml\filters\fadein_brightness
\Shotcut\share\shotcut\qml\filters\fadeout_brightness
Open the ui.qml file in a text editor. Change line 32
from
filter.set(‘alpha’, 1)
to
filter.set(‘alpha’, 0)

You can also use the opacity filter to do fades.
These presets will do it.
Fade In.txt (75 Bytes)
Fade Out.txt (111 Bytes)

Copy them to
C:\Users\username\AppData\Local\Meltytech\Shotcut\presets\brightnessOpacity
If you wish to use them.

2 Likes

This will not work with the primary use case of fading on V1 because V1 is not blended with the hidden black background as a performance optimization. If it did do blending, then it completely makes sense to remove the option and simply fade the opacity. However, the video processing performance is already an issue for most people in general such that I have not changed this model. Also, as a result of this choice, all upper tracks blend with V1 instead of the black background such that hiding V1 breaks compositing. If the performance improves significantly in the future then I will change these things.

2 Likes

@sauron It worked :+1: Thank you !

I always wondered why hiding V1 would break compositing, and this is an excellent explanation. Is there an appropriate place in the documentation wiki to preserve this explanation for other users? It is very useful information.