External Monitor behavior - Windows 10

Two Monitor set up.
Screen 0 is always main. (Windows 10 - Display 1)
Screen 1 is always external. (Windows 10 - Display 2)
Windows 10 settings - set to “Extend these displays”

Display Method - Open GL

  1. Open Shotcut (default state of no external monitor)
  2. Open File MP4 or PNG
  3. Settings - External Monitor : Set to Screen 1
    Image is displayed properly on Screen 1
  4. Click anywhere on Shotcut in Screen 0, turns Screen 1 to solid green.
    a. Clicking over on Screen 1 does not resolve it.
    b. Can drag from Screen 1 (showing all green) to timeline. This restores function to Screen 1.

Display method - Direct X

  1. Open Shotcut (default state of no external monitor)
  2. Open File MP4 or PNG
  3. Settings - External Monitor: Set to Screen 1
    Image is displayed properly on Screen 1
  4. Settings - External Monitor: Set to None
    Timeline is obsured. No way to get back the timeline, have to restart.

    Makes no difference if clip is loaded into the timeline before going to Screen1, same result.

I’ve also tried turning the timeline off, then turning it back on, still the same result with Direct X.

Video mode : Automatic
Scrub Audio/Realtime/Progressive (all off)
Theme: Fusion Dark

Shotcut 19.08.16 64-bit (Github)
Windows 10 Home 1809 (17763.678)
OS/Shotcut on SSD 1
Media files on SSD 2
i7-7700k 4.2 GHz Quad Core, Z270 Mobo, 32gb ram
ASUS ROG GTX 1070 Strix (8gb)
GeForce Driver: 436.02

Related to

I have done just all I care to do on this except to require app restart. For now, use it if it works for you.

1 Like

Fair enough. It’s not a deal breaker for me. I’ve experienced this in the past, and always restarted. It’s not a big deal for me as I don’t use this feature much. At first I thought it just happened once in a while until I experienced it twice today, then did it a few more times to confirm it.

As always I do appreciate the work you’re doing. :slight_smile: