Extending a video clip should not split up parallel audio clip

I want to extend a video clip where there is also an audio track in parallel and some other audio clips follow later. So the only possibility to keep the audio clips in sync with the later video clips, I have to enable “ripple” and “ripple all tracks”. But then, the audio clip is split and a gap is created.

It would be better, when the audio clip is kept as one and just after the audio clip the additional time (the one from extending the video clip) is added by Shotcut.

This is how Ripple All Tracks works and will not be changed. If you do not want another track affected you can either lock it or turn off Ripple All Tracks temporarily.

So there is no other way to avoid that a parallel clip is split AND the later clips are kept in sync?