Exporting to WebM (VP8) produces the same filesize no matter the resolution (maintaining the bitrate), QbVBR does not work, ABR = CBR


#1

Hello,

exporting to WEBM using “WebM” preset (classic VP8) produces the same filesize no matter the resolution (maintaining the bitrate) - why? This is really weird. Filesize changes only when I change the bitrate.

Exporting to MP4 using “YouTube” (mp4) behaves correctly (smaller resolution => smaller filesize).

Particular resolutions I’ve tried are 1920x1080 and 960x540.

I’ve got “Settings -> Video mode -> automatic” set, running the latest version (but it’s been behaving like this at least one year already anyway) on Xubuntu 17.10.

How can I fix this?


#2

Tried the WEBM export VP9 there is no VP8. 480x360 clip and 1280x720 clip using defaule Average bitrate. The results are different filesizes.

image


#3

If two videos have the same bitrate and the same duration, they will have the same duration, no matter the resolution.

Bitrate means “bits over time”

For example: a bitrate of 2Mb/s in a video that is 1m30s long (90 seconds ) has a file size of 180 Mb (22.5 MB).
No matter whether the video is 4K, 1080p or 720p, the encoder will limit each second to 2Mb size.

If you want the size to change, you need to allow the bitrate to change.

I’m not sure if “Quality-based VBR” lowers the bitrate based on resolution though. You might have to do it manually. (Although re-reading OP it seems that it does).

The default WebM/YouTube settins show that they use different Codec defaults.

image

image

PS:

When setting average bitrate, the codec might not use it all up. For example if I render a 14s long 1080p video of a black image with sound by disabling the video of the only video track in shotcut, even if I set the average bitrate to 80Mb/s, the resulting video will be 274KB in size, not 1260Mb (157.5MB). So even if you set a certain average bitrate, the video that comes out can have a lower bitrate (you can measure it by dividing the size of your video in bits by seconds).


#4

@sauron : yes, there is VP8, it’s the “WebM” option (in contrast to “WebM VP9”)

others:
I am using this setting: image

The point is no matter the resolution set in “video” tab, the resultant exported file has got always ~100MB.

OK, it might be caused by the “Average Bitrate” setting, you say, so I’ve made a test trying all four options the “libvpx” option provides me. Here are the results for ~13sec video:

  1. 1920x1080 using “Average Bitrate” (default): 8MB file
  2. 1920x1080 using “Constant Bitrate”: 8MB file
  3. 1920x1080 using “Quality based VBR”: 471K file (no video there ! )
  4. 1920x1080 using “Constrained VBR”: 1.6MB file

reduced resolution:

  1. 960x540 using “Average Bitrate” (default): 6.2MB file
  2. 960x540 using “Constant Bitrate”: 6.2MB file
  3. 960x540 using “Quality based VBR”: 471K file (no video there ! )
  4. 960x540 using “Constrained VBR”: 872K file

Which brings us to this:

  1. Quality Based VBR does not work at all (produces file without video, only audio is being played)
  2. There is no difference between ABR and CBR
  3. Today, changing the resolution, for some strange reason, has resulted in smaller filesize (?!) - I do not understand why, will have to make some additional tests.

#5

My bad about that. Didn’t know WebM is WebM VP8.

Tried exporting 1280x720 9 sec clip and I got the same results you got.
Average and constrained yielded 2.54MB files.
Constrained 1.8MB
Quality VBR 18.4KB No Video.

I don’t know why this is happening. But a reduced resolution still created smaller filesizes.

Also tried an export with constant at 4M bitrate and average at 4M bitrate and got 4.29MB files.