Exporting taking a very long time


#1

Hello everyone!
I’m new to using Shotcut, and have been using YouTube to answer most of my questions, but now it’s time to export my video and it is taking a strangely long time.

My video is 6 minutes long and rendering is taking 42 minutes.

In my video, I’ve put together two video tracks, with a cross fade connecting them, and two audio tracks. I am also using some filters:
Fade in, fade out, adjusted contrast and saturation, adjusted volume levels. I used the “Mute” filter for the audio from the video, and am using a separate audio track (Thinking this would help things…correct me if this is wrong)

I’ve set to export at H.264 high profile (I need HD video for this project…is there another way to make sure it’s HD?)
1080x1920
Codec: Quality based VBR, 70% quality.

My computer is a Dell Inspiron,Core i3 processor, 8GB RAM

Any thoughts or suggestions on how I can make exporting faster?

Thank you thank you thank you!


#2

Make sure your resolution is actually 1920x1080 (not 1080x1920).

I’m just a novice with this software. I’ve got an i7-7700k processor and for a 15 minute video (60fps, 12k bitrate) it takes me about 8 to 15 minutes. So depending on if you have anti-virus software enabled along with XBox DVR enabled to other conflicting software that eats up memory and cpu performance, I would say 42 minutes sounds right, based on the i3 processor.

Realize there are multiple generations (and models) of Intel i3 Processors out there from 5th gen to 8th gen all with different cores and specs. Then with Spectre and Meltdown patch fix’s/updates from Intel & Microsoft you could have the CPU that sees the 33% decrease in performance.


#3

Hi Rachel! When you say that you need “HD video,” what exactly do you mean? Do you have the exact specs needed for the final result? (For instance, will you be uploading to YouTube?) Also, what are the specs of your source videos?

If you need to do test exports that don’t need to be full quality, adding “preset=ultrafast” to the Other tab in the export options should make for a lower quality exported video while taking much less time.


#4

Are you reading and writing to the same drive? and is it mechanical? moving to faster storage can be huge and reading/writing to an hdd is very slow in general


#5

Thank you everyone.

I am quite a novice as well, so I don’t actually have more info other than that it should be HD. The videos are for Udemy courses.

I appreciate your responses, but for now I’m just accepting the fact that it will take about 30-40 minutes to export each video. In the end it’s not that bad. When I get a more tech savvy person to look at it directly I’ll look into it more.

The info on the “ultra fast” preset for exporting a test video is very helpful. Thanks John_solo!


#6

Not a problem, don’t hesitate to ask here if you need hardware recommendations in the future some of us have too much time and ran the benchmark @nwgat wrote on everything they could


#7

and unholy slow some of them :stuck_out_tongue_winking_eye:
and yeah veryfast should work fine on test project but on finaly you want medium or slow


#8

You should check your email I sent you a message there @nwgat :stuck_out_tongue: and yeah I know some of them are core2 but still in use!


#9

Perhaps you can lower the export quality to 60%. When you export at 70% quality based VBR it can take much longer. I don’t think there should be significant loss in quality for use on Udemy, but you have to test and see.

For clips recorded from a camera vs screen captured, that 10% difference in quality setting make quite a bit of difference.


#10

I can confirm the long time on export, used the version 18.03.06 of Shotcut under 64-bit Linux with 8-core and 64 GB RAM computer. I noticed that only one processor was used at a time with 100% load. Probably it would be possible to use all available processors? Nowadays there are multiple processors usually on computers and it would be useful to use them - presumably it would reduce the exporting time.


#11

Shotcut does scale to multiple cores but it is an option when exporting to disable it(and some codecs do not scale)