Exporting synched audio and video


#1

Shotcut newbie (but have searched Youtube and related posts on this query…) Using brand new Windows 10, and Shotcut version win64 180814. I have synched audio (using Samson mic and Windows Voice Recorder) with muted video (from Canon 100 DSLR) but when I export to mp4 using the following settings which match what the camera captures in (1920 x 1080, 20fps, audio:44.1KHz) the audio lags behind the video. Do I have to use Audacity or equivalent and/or have I got Export settings wrong? I am wanting to keep things as simple as possible! Any help greatly appreciated to sort this one - thank you.


#2

In Export did you change the Frame rate field?
What does Export > Video > Frame rate say when you open the project and go to Export?


#3

Yes - I changed the Frame rate from 25 to 20fps. So it currently says 20fps when i reopen the clip that I audio-synched.
I am hoping to post videos on YouTube and/or an LMS so is there a standard setting that i can choose to make life easier? The YouTube resolution for example is only 720x480 so I didn’t use it… My logic is to keep the video/audio quality as high as possible as simply as possible. I really appreciate your help - thank you!


#4

The YouTube preset does not alter your resolution. The resolution is defaulted from your project settings. The project settings are determined from Settings > Video Mode. If that is set to Automatic, the project settings are determined from the first file you add to Playlist or Timeline, whether it is still there or not and whether it is still first in time or not - the very first thing you add. Reducing the frame rate at export is introducing the problem, and there is already a fix for this in the next version.

You can workaround this in your version by changing the resolution in Export, but that is not optimal because the camera video is at 1920x1080, and scaling from 720x480 to 1920x1080 is not ideal. Also, there is very little point in reducing the frame rate to 20 as that is a very uncommon frame rate. You should stick with 25. Also, 720x480 is non-square pixels, and you should only upload square pixel content to YouTube. Thus, you should open your project in Shotcut, change Settings > Video Mode to something you want besides Automatic - something closest to the main video you use. Then, review the project and make any corrections needed and save.


#5

So I’m trying to show you what I’ve understood from your explanation…
The YouTube preset does not alter your resolution. I take that to mean the exported video. ok - i thought it wouldThe resolution is defaulted from your project settings.the resolution is set by the settings set when Exported The project settings are determined from Settings > Video Mode. If that is set to Automatic i can’t find an Automatic setting in Export, the project settings are determined from the first file you add to Playlist or Timeline, whether it is still there or not and whether it is still first in time or not - the very first thing you add.Ever? or just each time I open up Shotcut? I’m assuming the latter! Reducing the frame rate at export is introducing the problem, and there is already a fix for this in the next version. Maybe i just need to know when the next version comes out?!!

You can workaround this in your version by changing the resolution in Export, but that is not optimal because the camera video is at 1920x1080, and scaling from 720x480 to 1920x1080 is not ideal. Also, there is very little point in reducing the frame rate to 20 as that is a very uncommon frame rate. You should stick with 25. Also, 720x480 is non-square pixels, and you should only upload square pixel content to YouTube. Ok - I think this makes senseThus, you should open your project in Shotcut, change Settings > Video Mode to something you want besides Automatic - something closest to the main video you use.i think this means that i should change the Settings in Video Mode to settings closest to what the camera shoots in, which is what I did in the first place (and seems to have caused the problem!). it also doesn’t seem to sort the non-square pixels for Youtube problem Then, review the project and make any corrections needed and save. **I’m sorry that I’m clearly not understanding all of this. if you are able to clarify my current understanding that would be great but appreciate that might not be possible. This is really frustrating as i was hoping that i would manage Shotcut - maybe not…:frowning: **
in the meantime, I’m going to just try manually moving the audio slightly to see if this helps (advice from other video editors)! I really want to get audio synching working :slight_smile:


#6

I don’t know how you have your project set up, but if you’re trying to change frame rates, which 30 fps is the lowest YouTube recommends, I would detach the audio from the video.

For future recordings try to change your camera’s settings to match or exceed what you wish your final video to be.