Exporting as flac

Windows 10Pro
HP 840G1 laptop and Dell 7020 desktop
Shotcut 23.07.29 portable

This has been happening for quite some time, so it’s not new to the latest SC release, and I’ve been able to get around it by other means, but …

Exporting the sound track of a video file from SC to flac doesn’t really seem to work properly. I’m selecting flac audio from the preset and not changing anything. Firstly, when the export file manager window pops up, the default file exension is “Matroska .mkv”. Why is that? and not .flac? The export process does complete normally (apparently), but I can’t read the resulting file with other audio processing programs such as Adobe Audition. They report the file as being corrupt.

Now, I can extract a video file’s audio track directly by a drag&drop into Audacity, which will export to a .flac and that file can be read by other audio processing software.

So what’s so unique about the flac export from SC, that it may not be readable?



If you open it in Shotcut does it play?
Mkv is an alternative format for FLAC that works better in Shotcut than plain .flac although that has improved. Mkv format is not really a bug, but I think that can be changed to improve compatibility with other tools. After choosing the preset you can go into Advanced and change Format to flac to override it.


I ran a couple of tests:

Select the flac preset as-is and export results in a file with .mka extension (not .mkv as I said in my message). This file will play in SC but not in other audio software, except for Audacity. I suspect that my unresponsive audio software sees the .mka exxtension and says “huh, why are you trying to open a video file in audio software?”, then proceeds to ignore the file or throw an error. Audacity will load the file but only because it has the capability to directly rip audio tracks from a video file. Of course, SC will load it because it’s a Matroska video file.

Renaming the mka file to .flac doesn’t work either because the file itself is still a matroska video file with null video content.

I did as you suggested and selected flac format in the advanced-audio settings. That will result in a default export to .flac and the file will load in my audio processing software, so it is a true flac audio file.

Out of all this it appears that the default setting of the flac audio preset is actually a matroska video file having no video content. I think that this should be changed to default with the flac format loaded into the preset. The presets for .wav and .mp3 load those same formats in their defaults; why should flac be any different?

In case you’re wondering why I’m doing this, it’s because I’m cleaning up the audio tracks in video files to remove DC offset, AC line harmonics and sometimes even background noise as well as level normalisation. I find that dedicated audio software works much better than SC at doing this and I use the .flac format to keep file size down with lossless compression. The cleaned up file is then imported back into SC as a separate audio track to the original video file, the video’s audio is disabled and I recode into HEVC.


Matroska is not a video file. AVI, MP4, MOV, etc. are not video files! It is perfectly legit to have only audio in any of these files and very normal in the case of MP4.

why should flac be any different?

I kind of already told you. Shotcut historically did not provide seeking on .flac files; so, it was problematic to export to something that does not work in Shotcut. This was fixed only in 2023 versions.

Update: I changed this preset for the next version to make a .flac file

1 Like

I’ve been away on other things but do want to thank you for addressing this issue and doing the fix in the most recent releases. The flac export is now working as I had expected and the file itself is directly readable by my audio editing software.

Yes, I should have been more careful in describing .mka as a container rather than a video format. My bad.


1 Like