Exported Video Yields Choppy, Jumping Text


#1

Hello,
I just started using shotcut a few weeks ago. Relatively inexperienced to video editing in general. I wanted to create individual screens of text that pause just long enough to be read. I inserted a black screen .jpg, added text filters with fade in and out video and it does exactly what I wanted it to do in the player. When I export the video, the text (which is perfectly still in the player) jumps and moves back and forth; not all the text, sometimes only 1 line out of a paragraph is affected. I’ve tried the h264 baseline profile and youtube formats. I can’t seem to find one where the text doesn’t jump.

I have noticed that on one of the screens with humping text, I had applied two text filters with the intent that some of the text was italicized. It didn’t seem like I could get text with varying sizes or fonts within the same filter. I am also experiencing it on stills with only 1 text filter, so that would disprove this theory.

I don’t know where I can post a copy of this video to demonstrate what I am talking about, if that would be necessary.

Overall, I am impressed with the quality of the video that I made, but I made the video for an animal rescue project I am belong to, with the intent to post to social media. With the jumping text, it doesn’t look remotely professional and is unusable. I am playing back the video with vlc player and windows media, and am getting the jumping on both players.

I upgraded to the latest version in the middle of this project. Prior to today I was using the last version as of a few weeks ago (sorry don’t remember number). I am using windows 10 x64

A separate issue, perhaps one that is contributing to this one, was that I needed to lengthen the clips because I didn’t leave enough time for the text to be read. My inelegant solution was to add multiple video tracks so that I could lengthen those clips. Perhaps there are too many tracks that are gumming things up during compilation?

I appreciate any advice you can offer. The video is good, it plays fine in the player, just can’t get a finished version that looks as nice.


#2

Ok, so I figured out how to publish this to youtube, which I didn’t really want to do because it’s not finished, but you can see what I’m talking about. The first wall of text at 0:05 with jumping occurs, and it happens throughout the video. It also is noticeable starting at 3:15. Hopefully this is more helpful


#3

Searching the forum could have saved you a lot of time.
Already been addressed, and will be fixed next release.

This only affects the text filter.

A couple of work-around ideas to get the project finished.

Step 1. File - Save As and save to a new file name. (Example - “oncemoreX1.mlt”)

A. Locate a frame of text, Export Frame. Import that image on a video track above the video. Then just uncheckmark the text filter.
shotcut_2019-01-17_00-32-28

B. Use GIMP or some other free graphics editor, you could just type you your text, export to PNG, and insert onto a video track above your main video.


#4

I really appreciate your reply. I’ve searched forums before, never wanting to be that guy, but for some reason, whatever search strings I was using, I didn’t see that post. In any case, that solved my problem (exporting the frame, then just readding the exported frame and disabling the text filter) and I am grateful. It did take me some time fiddling around with different formats before your help.
Thank you!


#5

The easier work-around is to disable “Parallel Processing” in the advanced export settings. This issues is fixed for the next release v19.01.x later this month.


#6

#meetoo :smiley: -> https://www.youtube.com/watch?v=WloJSO_rPnI
(Shotcut v18.12.23, Win10pro ENG x64, …)


#7