Exported video transparency problem


I’m new to Shotcut. I recreated a problem to a fresh file that I’m having with my main project. So, when I edit my videos in the timeline everything is just as it should be (see attachment 1). When I export the video (with default settings) the export shows only the top layer and with no transparency effects. If the clip is smaller than the project resolution, the rest is black instead of showing the clips underneath. When the top layers clip is finished, the layer beneath appears in the export. If I use a color filter, it works in the exported version, but if I use for example Chroma key or opacity, they won’t apply to the exported video. Thanks in advance!

I do not get the same. Default export.
Direct video link

Again, I’m not getting the same results. Default export.
Direct video link

Thanks for your time!

I don’t get what is the problem in my end. I should also have everything as default settings. This seems to be a bug then?

I read someone suggesting a composite mode or something to a similiar issue in an other thread, but I don’t seem to find that composite or blending modes anywhere.

Not entirely sure what you are trying to accomplish.

Here is where you can find the blend modes.

Track blend modes higher than V1.
Click on a track header, then properties.

You can also apply blend modes to clips.
Select a clip, then apply the blend mode filter.

A bug is something that can be repeated. Best to list the minimal amount of steps needed to recreate the issue.

Yep, blend modes didn’t help.

I can’t seem to figure this problem out. It seems to be a bug, since I have recreated this problem twice now. I open a new project, add two videoclips, export, and only the top layer is showing in the export. I’ve read all the threads related to this issue, but nothing seems to solve this one.

Can you upload your mlt so we can see what filter settings you’re using?
Just drag/drop your mlt file in the reply window.

Works fine for me. Default preset.
I did apply a Crop: Source filter to the clip on V1 to match your Video Mode resolution.
Direct video link

Without the Crop: Source filter
Not sure if you wanted to have black bars on the sides.
Direct video link

If the project file works in your end, could the problem be in my software itself? I don’t know if there is something wrong in the export part then, but I have reseted the settings to default many times and I’ve reinstalled the whole program once.

I also can’t replicate the problem

Without the Opacity filter

With Opacity filter

I’m using Shotcut version 22.03.06 on Windows 10
What are your Shotcut version and operating system?

I’m using windows 7, maybe its a bug in this operating system?

Here are the filters @jnsk1 used on the clip on V2. (Pasted in a text file)
filters.txt (2.1 KB)


Just as a test, try moving the Size, Position & Rotate filter to the bottom of the filters list and see what it does.


That didn’t help. I don’t think it is in the project file or in the filters as it works for everyone else. It must be in the software or in the combination on software and operating system.

Looks like I have to change to another software, since I just can’t solve this bug. Which is unfortunate, because I really liked this one and also worked for hours already with the project.

Good luck to you.
But don’t cut all bridges with the forum. Maybe someone will think of something to help find a solution.
By the way, you didn’t mention the version of Shotcut you installed.
Also, is your Windows 32 bits or 64 bits?

Yes, I’ll be checking if someone replies to this problem and maybe has a solution.
I’m using the latest version of Shotcut that I just installed couple of days ago. I have a 64-bit Windows.

This topic was automatically closed after 90 days. New replies are no longer allowed.