Export Transparent Video

What is your operating system?
Windows 10 (64bit)

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Shotcut version 20.09.27

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
Creating a small clip with V2,V3,V4 (Text filters) on top of V1 (Main Content) displays tranparency fine before export but after export to Alpha Preset Quicktime or UtVideo, it causes V3 to lose the alpha transparency channel. In other words as I play the final export video, the text in V2 shows a tranparent background until it plays into V3 which is a layer above V2 and then it loses the transparent background.

I’ve attached my example:

SampleLoseTransp.mlt (19.2 KB)

I can’t duplicate the issue you’re having.

From your MLT (I had repaired it with a 1920x1080 yellow solid color png)

Did you export that video into another project (minus the V1 background track) and place that exported video over another video?

If you want a true transparent video you need to export with WebM VP8 or VP9 with Chroma Key: Simple (black) on Output. I usually have better luck with VP9.
Video used in OBS Studio


When using multiple tracks transparency will not be preserved no matter which transparent export preset you use.
Open XMl as Clip will not work either.
You need to put all the text on one track then export using one of the transparent presets.

SampleLoseTransp 1 Track.mlt (14.0 KB)

The attached project uses one track.

Result using QuickTime export.


Thanks @sauron for correcting me… I thought I’ve had it work before, but I am mistaken.
Nice work.

Hmmm, interesting. How did you merge the layers? When I tried copying the text filter to a lower layer, it split the clip

You can’t merge the layers, rather copy/paste the filters to a transparent image/color on V1.
Like this: SampleLoseTransp7.mlt (9.5 KB)

When you copy/paste filters, you’ll have to trim each filter.


When I create a transparent color on V1 layer, I started by just copying the THANKS text-filter and pasting it into the V1 transparent layer and it splits the clip.

shotcut_2020-09-28_15-11-34 shotcut_2020-09-28_15-11-48

Thanks @Hudson555x & @sauron.

Great to know I’ve got 2 options in the future. @sauron , that option is easier, @Hudson555x , that option is a mess BUT it’s nice to know. Would be nice to have a merge feature. With copy and pasting there are a few time consuming and confusing issues:

  • When I copy more than one text-filter, it can become a mess of filters in the resulting transparency track V1. There is no distinction between which filter is for which text. The more text motion and fades, the resulting filter list is a complete mess.
  • It takes so much more time to fix all the fades and movements than a simple merge.

Good to know again that with ‘time’, on a ‘large time-line’, I can at least accomplish what I set out to do in the first place. :slight_smile:

Thanks again.

True, with no filter selected there is no distinction.

When you select a text filter (Simple or Rich) there is a VUI (Video User Interface) that appears in the preview for that text filter.

Yes thanks understood. It takes time to get used to and takes a bit more time to wrestle it for more filters but I can’t say it’s not functional. Thanks again I appreciate it!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.