Export Time is 6x Longer in every Version after 19.01

Hi All,
I’m not quite sure if I categorized this correctly, I imagine that this would have been brought up by many others before me if this was truly a problem for everyone across the board, but I couldn’t find any articles or solutions myself when looking. I’m the kind of person who wont upgrade software (or hardware) until I am using a seriously outdated version (basically my belief is, if it aint broke, don’t try and fix it) but after seeing months of awesome updates and additions to Shotcut I decided to move from version 18.11 to the newest version 19.10. Everything was mostly fine (if not great!) before I got to the point of exporting. Whatever it is I want to export using 19.10 takes approx. 5 to 8 times longer than it did in 18.11. I ran a couple of tests, firstly, to keep all things the same, I used an 11min clip that did change at all throughout my testing. I used the same exporting variables each and every time. My computer did not change and its specs are as follows: HP Pavilion Laptop, Win 10 Pro, i5-8300H, 16gb Ram 1TB HHD with Intel Optane Memory-16gb, and 2 GPU processers, Intel Graphic 630 and Nvidia GeForce GTX 1050 4gb. I downloaded every single version of Shotcut between 18.11 and 19.10 and the only versions that continued to export normally were 18.12 and 19.01. Starting with 19.02 through the current version, exporting for that 11min clip (which would take 8min & 12sec to be exact) is now taking 45 -1hr & 15min depending on which version I’m using after 19.01. Every version after 19.01 along with taking 5-8x longer also makes my machine run at full output as if there is a problem, (to be specific my CPU always runs around 100% for every version, however my cooling fan runs at around 50-70%, but when I use version 19.02 and after the fan runs at 100%.) I used 3 variable sets throughout every single version to make sure that it was the same problem for me across the board each time. If anyone has any idea what exactly the problem is or if they already had the same problem and found a solution please let me know, as I would love to use the newest version with the fantastic updates!

Which export preset? Hardware or software encoder?

Software Encoder, I do not use presets, because I work for an entertainment company which does events, so the video we shoot and edit has to come out exactly as the client paid for it, certain quality requirements etc. I used the 3 variable sets which are as follows… Set 1: Format: Mp4 - Video Tab: 720x480p - Aspect ratio: 16:9 - Frames Per Sec.: 29.97 - Scan Mode: Progressive - Deinterlacer: Best - Interpolation: Good - Parallel Processing: ON -Codec Tab: Libx264 - Average Bitrate: 2M - GOP: 13 - B-Frames: 3 - Audio Tab: 2 Channel - Sample Rate: 44100 - Codec: aac - Average Bit Rate: 96k
Variable Set 2: Format: Mp4 - Video Tab: 720x480p - Aspect ratio: 16:9 - Frames Per Sec.: 29.97 - Scan Mode: Progressive - Deinterlacer: Best - Interpolation: Good - Parallel Processing: ON -Codec Tab: Mpeg4 - Average Bitrate: 2M - GOP: 13 - B-Frames: 3 - Audio Tab: 2 Channel - Sample Rate: 44100 - Codec: libmp3lame - Average Bit Rate: 96k
Variable Set 3: Format: Mp4 - Video Tab: 720x480p - Aspect ratio: 16:9 - Frames Per Sec.: 29.97 - Scan Mode: Progressive - Deinterlacer: Best - Interpolation: Good - Parallel Processing: ON -Codec Tab: Libx265 - Average Bitrate: 2M - GOP: 13 - B-Frames: 3 - Audio Tab: 2 Channel - Sample Rate: 44100 - Codec: aac - Average Bit Rate: 96k
I used these 3 variable sets across every version of Shotcut from 18.11 to 19.10. All 3 variable sets worked normally on 18.11 -19.01 (Normally meaning, time it took to export and what speed my cooling fan was running at) and then from 19.02 on, started making the export 5-8x as long and making my cooling fan run at full speed, as if the processer is running much hotter when exporting in these versions with the same export parameters than the first 3 versions.

I just made a test by adding a single 10 minute 1080p60 video clip to the timeline and exporting without hardware encoding. I compared export times of versions 19.01 and 19.10. 19.01 was 8:12 while 19.10 was 6:20 (faster). The source was progressive so deinterlace was not a factor, but the deinterlace code did not change between these versions. Is your project 720x480? Are your sources interlaced? The best deinterlacer requires previous and next frames, and it is possible that something related to accessing these frames has changed. It is possible something else you are using in your projects has regressed severely. I will run a deinterlace test next.

In my deinterlace test v19.01 took 5:16 and v19.10 took only 3:13.
So, I am at a loss as to what is going wrong for you. Try to ensure the project is the same resolution and frame rate as what you are exporting. That has a big impact on how export runs.

I made another test where I scaled the resolution at export time (source 528x480 -> export 720x480). In v19.01 this took 7:13. In v19.10 it took only 3:02!

I am at a loss to understand the source of your 5 - 8X slowdown.

Great list of export settings, thank you for going to the effort to document all of it. At the risk of asking for more, what filters are you using? Another recent thread talks about slowdowns and they are using a lot of filters, so we may be able to isolate the slowdown to a specific filter.

To answer Dan first, my project source is 1080p 60F but I am exporting in 720x480 30F. I completely understand that exporting out a different resolution would take longer than keeping it the same as my source, (I’m not complaining about the time export takes in general, if every version for me would be the same amount of time, long or short I wouldn’t say a word) but the thing I’m so confused about is that, I am keeping everything the same in version 19.01 as I am in 19.10. Same 11min clip, same resolution and codec for export, etc. and yet I’m getting that slowdown in the latter version.
Austin, for my purposes of finding out what may be causing the slowdown between the versions I completely stripped my timeline/project of any filters and transitions at all. (I figured like you mentioned, that would make it much harder to determine what may be the cause of the slowdown) I will attach a couple of pictures of what I see on my screen when I start the export, a picture is worth a 1000 words, so you guys may see something I am missing that may help. I will put up a screenshot or 2 from each version 19.01 and 19.10

Alright, so I am attaching two pictures, one is a screenshot of running the export on 19.01 and in the top right you can see at 4% export it says it will take 8min, and the second picture shows that I waited until 30% export and it still says 11min left.
I really wanted to show you guys when I start an export, it will say 45min or longer… but sometimes it doesn’t do that, it just keeps moving the time up and down around 10-20min range throughout the entire export process and still takes the 45min or longer.
While I couldn’t show you exactly what I wanted I think the pictures will still show you something is wrong. How can it be that the same exact export in 19.01 will take 8min to finish when at 4% and in 19.10 at 30% it still has longer to go than the entire export time on 19.01.

Have you use a wall clock to know the real time that it took for the exports to complete? Or are you only trusting the prediction that the export panel shows you.

Predicting the time it will take to export is difficult and not very accurate. I wonder if the prediction is different between the versions, but the actual time is the same?

The actual time is reported when the export finishes.

I have used an external clock to time it, yes, and it matches very closely with the actual time reported when the export finishes, which is also very close to the predicted times that it shows throughout. For instance, I also tried with a much shorter clip, rather than an 11min. clip, I tried with a 10 sec. clip, and with 19.01 the 10 sec. clip finishes in approx. 15 sec. and on 19.10 it finishes in 1min 30sec.

What is the project resolution? You can see the project resolution by clicking “Master” in the top, left of the Timeline and viewing Properties. If the export resolution, aspect ratio, or frame rate are different than the project, then the export process goes into a special mode. This is discouraged and should only be done for special situations. This is what I meant by:

Also, be aware that in version 19.01, I made a change such that if export fails, it restarts the job parallel processing disabled. I know you said after 19.01, but it is possible in your 19.01 test that you did not experience an export failure. Export failures due to parallel processing are intermittent, which is why this change was made. When this happens, there is a status message below the player controls that says, “Export job failed; trying again without Parallel processing.” (This will also get logged to the application log in the View menu).

I made another test using Video Mode = Automatic, 1080p60 source (project becomes 1080p60 as a result), and changed my export settings very close to your set 1, thus putting it into that special export mode. Using v18.12, export took 5:04. Version 19.10 took 4:03.

Maybe if you are loading an old project file for these tests there is something hidden that is affecting things. Can you please make a simple test where you first change to Settings > Video Mode > Non-Broadcast > DVD Widescreen NTSC, open a single file, add it to the timeline, ensure Export > Scan mode is set to Progressive, and export?

Also, please confirm your source is progressive as you claim as .MTS file name implies AVCHD, which is quite frequently interlaced.

I have prevoiusly reported the same issue. But then different Export Time for windows vs. Linux version. So yes, the issue exists. However, my observation is that export time is not always longer. Strange.

Note that I have used:

  • same source files
  • no gpu processing
  • FRESH install of the downloaded package
  • it has been tested on SAME hardware. Giving different export times…

*** I downloaded the latest version, and instead of about 4-5 min export time for my tests, it said “30+ min”. And the computer chewed for a long time, I cancelled because I did not have the time…

I really really do not have the time to deal with this. But I will some day look into creating tests and uploading my raw source files.

Hint: One observation was that single-source, no edits, would export speedy. More than single clip, and/or with edits, would take longer.

Best Regards from Jan

Any reports about time estimates provided in the jobs panel is useless as they are not reliable numbers.

Now I have tried some different version. To no success. But, the problem is real, exists. However, it manifests itself “randomly”.

When I test, I use tow of my own files, so I know more or less what the time should be. I install from the source package, then:

  • click Timeline (to get a timeline)
  • Open file (and select my 2 files) (I wait for the loading)
  • drag both clips onto the timeline (wait for it to process)
  • remove gap between the two files
  • Export
  • change resolution (from 4K) to 1920x1080
  • export (as MP4, nothing changed from what the package comes with, so no special soft or hard encoder, nothing special. whatever presets have been changed in the package… I don’t look for that, I don’t expect that)

Computer A. HP z620, Xeon E5-1620 V2, 4-core 8 threads, 8 gb mem, ssd disk. Windows 10 (1809)
ver-170904 export 09:00 size 155.939
ver 190414 export 06:53 size 94.508
ver 20191020 export 06:38 size 94.508

Computer B. Dell laptop i7-4600U, 2 core, ht disabled. 16 gb men, ssd disk, ubuntu 18.04
ver-170904 export 12:50 size 159.590
ver 190414 export 13:30 size 96.758
ver 20191020 export 13:30 size 96.758

In this case, nothing much to complain about. BUT, I have seen extremely slow export times. So something is randomly strange. A report will come again, when I see the problem.

It might have something to do with (these are things that I would like to explore)

  • more than one video on the timeline
  • that there are edits
  • I have done export as webm sometimes

Best Regards/ Jan

@ZR18 I had the same issue, what I (we) failed to realize was the newer versions do not use the same quality values. if you used to use 90% with v18, then
try 70% for v19.02+, (but really try 61% and maybe 65% and see if you can even tell a difference.)

for reference 60 & 61% is like crf=20; whereas 64 & 65% are like crf=18. i never needed lower than 18 (never needed higher than 65%)

i do 65% for youtube published and 61% for youtube unpublished. (always 1440p or better for youtubes’ re-encode degrading)

@ndq0345934 Keep in mind, like I show in the pictures above, I don’t use a percent quality value, I use a static number, and in this case, an average bitrate of 2M. So in that case it must be so thing else, since my original post I have paid close attention to what Dan had said, and I specifically didn’t realize we shouldn’t be using shotcut to export different quality videos then our source, or a special export starts… I always used shortcut as a means to change the quality of videos we shoot. Either way, while I still generally see longer export times in the latest version, doing a couple of things mentioned above has definitely helped

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.