Export takes over 7 hours


#1

I am trying to export a video that is in 1080 59fps. I have joined a 40 minute video to a 12 second video. I have set the export options to
Video:
Scan mode progressive
deinterlacer YADIF - temporal + spacial
interpolation Bilinear

Codec:
Codec h264_nvenc
Rate control quality-based VBR
Quality 100%
GOP 30
B fames 2
Codec threads 0

Audio:
Channels 2(stereo)
Sample rate 48000
Codec aac
Rate control Average Bitrate
Bitrate 320 k

Other:
movflags=+faststart

My computer specs is:
Processor intel core i7-7700HQ CPU @2.8GHz 2.8 GHz
Installed RAM 16GB (2x 8GB) DDR4 at 2666MHz
NVIDIA® GeForce® GTX 1060 with 6GB GDDR5

On other editing software, it takes around an 1 hour and 30 minutes. What is wrong?


#2

What are your Source files specifications? (Format/Resolution/FPS)
What is your Video Mode (Settings/Video Mode) set at?
GPU Effects (Experimental) turned off? Yes/No
Operating System?
Any filters used?
Export format?

If this is for YouTube, have you tried the YouTube preset?


#3

The files are mp4, 1080p 60fps and 1080p 30fps
video mode is set to 1080p 59fps
GPU effects are turned off
windows 10 pro
no filters,
exporting to mp4

I have tried the youtube format, but the codec libx264 causes my CPU to max out at 100% for some odd reason. I have also tried just switching that to the h264_nvenc, holding all else true but the same problem persists.


#4

That is a good thing. I do not know why it is taking that long unless you are using multiple tracks with clips/images with alpha channels that requires blending/compositing.


#5

IMO, there is no reason to use a 59fps export framerate. It won’t gives you a better result, just a risk of creating artefacts.
I would stick to 30 fps. Or maybe 60, if this is the main material FR and if the videos requires it (action sport or very quicks moves…).


#6

hi all) i am very glad be here)


#7

OK, thanks anyways


#8

Is there a reason why you are choosing 59fps?


#9

I just put it into my head that it would save me a small fraction of time lol


#10

hi everybode)


#11

Why did you crank the quality to 100% and I would use the x264 encoder you’ll get better output.


#12

I put it up to 100% because I want my file to be the same quality as it was recorded.


#13

Assuming your file was h264 it isn’t “100%” by default since that produces massive files. Please try just the youtube defaults


#14

100% does not mean “make it the same as the source”. The encoder doesn’t know anything about your source file. That source file may have originally been encoded with a setting that is close to 50%.


#15

As there are no filters, why not convert the short video to the same framerate as the long one and join both files directly with ffmpeg? It would take minutes instead of hours, and the output would be 60 fps, very close to the 59 fps you get in 7 hours.


#16

Now I have no idea what is happening. The program fails to respond when exporting files.


#17

I just think the software doesnt like my computer, lol


#18

Exporting is a long process especially on slower systems @Valkyn unresponsiveness isn’t abnormal there.


#19

I don’t believe my computer is slow…


#20

I haven’t done much testing at 100% or a 7700 so I can’t say for certain but I know exports can take quite some time on a desktop i5-7600k. the 7700hq is a mobile chip and if you don’t have an SSD that 100% setting could really be punishing you.