Export seems to have quit

I am learning ShotCut. Finally made a useful project with 2 video clips pip’d on a still image clip and with an added audio track. Exported fine first time to a mp4 file which played perfectly as Quicktime movie. File size about 64 MB

Went back to project to adjust position of one of the video clips. Exported again same way as before with new name. Now only plays as audio in Quicktime and file size only 6MB.
Have repeated steps using several changes in export setting. No Luck.

What has happened?

Short Cut 20.04.12 on MacMini running OS 11 (El Capitan)

Can you show a screenshot of your full timeline?
What changes did you make?
If you click on “Default” in the Export preset (don’t enter advanced) do you get a clean export?

The best way to test an exported file is to opening it in Shotcut or a program like VLC.

That is not entirely correct. A player with this name is still included in MacOS. They simply dropped the framework with this name.

Hard to say, but sounds like you were changing things in Export’s Advanced mode, which is an easy way to break things if you do not really know what you are doing. If you not have already tried this, you definitely should: restart Shotcut, reopen the project, don’t change anything in Export, and simply click Export File. Wait for that to complete or fail! If that does not work you need to right-click the job, view log as .txt, and upload it here in a reply.

[Derp :hot_face:]… thanks for setting me straight. Thinking I misunderstood what I’ve heard about it from Twit.

I appreciate the quick replies. I tried again to duplicate the problem and made a screen shot of the app window as requested (attached). I also screenshot the directory where the first and second attempts to export worked successfully. This morning export was named foo4 and you can see that it is an mp4 file, but compared to my earlier exports is too short to be comparable to the 2:30 video it was supposed to render.And it only plays as audio.
PS. double clicking an mp4 file opens Quicktime by default.
OK I have finished typing but I can’t find a way to attach the screen shots. Help!

The “upload” button is show in the screenshot below:

Thanks all for the replies, but time has passed and I have just gotten back. To Hudson555X the only change made in the time was as slight reposition of one of the two video clips. So I have Reloaded the original project and did export again using all the defaults. Worked this time, but the reliability of the export feature worries me. Created a second project with simpler clips and exported OK to mp4.
BTW, for anyone interested, this is a great alternative to iMovie which has many supporters as well as many complaning about the error they get when exporting. problem is, Apple doesn’t seem to offer any help, except, maybe, to get another Mac with a newer OS and a fresh version of their app.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.