Export filename no extension?

Quick little question, is shotcut suppose to append a file extension when using the export file button and choosing a container format of mp4 ?


  • macos 10.13.6
  • shocut 19.12 installed via brew cask

I’ve noticed for as long as I can remember, and I always have to manually go to the file name box and add a .mp4 to the end of the filename. Let me know if there is any more information that I could provide to further diagnose this issue, or if this is the intended behavior of clicking the export file button in shotcut.

1 Like

Automatic filename extension only works when using the defaults or a stock preset. If you change Advanced > Format then it is reset to no extension (user-supplied) because many formats support more than one extension. If you want a custom preset to include a filename extension, then in the preset save dialog add a line like:

1 Like

not exactly sure what you mean by preset save dialog?

are you referring to the box outlined in the purple below?

1 Like

You can add it there before you save a custom preset, but it will not do anything until you save it as a custom preset. I meant when you click + to add a custom preset.


If you want to update an existing preset you can re-add it with the same name, or edit the preset file in a text editor: Settings > App Data Directory > Show… > presets > encode.

1 Like

as always thank you very much for prompt reply and added explanation to your first response.

would it not make sense to provide a Update button in the presets so if one wants to update a preset after changing a couple of values they click the Update button similar to how you added the functionality to update the IMG icons when a image is added to the playlist? and just present a dialog box, saying something like current preset settings are about to be updated

it’s a little convuluted on how the current workflow for updating presets works, but that just IHMO.

and manually editing the file that you described in going to the shotcut app directory got me what i was after. thank you :pray:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.