Export fails when exporting in ProRes mov QuickTime with Images (qmelt crashs)

OS X 10.11.6; Shotcut 17.04.02

I’ve got that when exporting intermediate/ProRes mov with fade-in and fade-out transparent images with Titles in second video track. It’s noteworthy I can export without crash H264 Main or High Profile mp4.
Transparent images are done by using File -> Open other… and then choosing “Color” in “Generator” -> Preselection “Transparent Title” (translated from french interface) and Titles using Title from Filters.
Rushs put in timeline are AVCHD mts or QuickTime mov.

Attached crash log from the OS: Shotcut_2017-04-16-151947_Mac-mini-1.crash.zip (27.7 KB).

Curious why you’re exporting a finished edit using ProRes?
ProRes is an intermediate codec (for the edit) rather than a delivery format as far as I know?.

I encode the ProRes master with another tool for delivery Hybrid. Hybrid is more efficient than ffmpeg in Shotcut to encode into h264 mp4 (better quality to size ratio).

I would also like to add that I can export successfully when my editing doesn’t contain titles at all and I get the same export failure when using transparent png images done in The Gimp as an alternative.

Though Hybrid is a converter, not an editor. I’m sure that makes a difference.
You could also use Eyeframe for ProRes output.

Just to clarify ProRes master is obtained from Shotcut and then encoded into delivery format with Hybrid.

I have transcoded upstream all my AVCHD rushs into ProRes/PCM mov with ffmbc before doing editing in Shotcut but I get the same crash when exporting…

This bug is not critical for me as I can export into mp4 but it would restrict the usability of Shotcut.

I’ve got the same bug with only one title on another project as explained in my first post. Could the devs have a look at the crash log?

This bug is randomly reproducible with others codecs in different containers (almost every attempt with ProRes or DNxHD in mov and less often with h264 in mp4 contrary I stated before) on my platform (OS X 10.11.6).

I can help to debug if necessary.

Here is a link for a very short project with only one title and OS X crash logs (ProRes and DNxHD in mov export):

I have finally found how to avoid this bug! I deselected “Parallel processing” (translation from french) in Video tab and now I can export without crash.

you can adopt the hybrid profile into a shotcut export, can you tell us the profile you use?

to get a lower filesize with better quality you can do something like use preset=slower with crf=24 etc

Here is the Hybrid profile used as shown by MediaInfo,

cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x111 / me=hex / subme=5 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=0 / threads=12 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=0 / crf=20.0 / qcomp=0.50 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=62500 / vbv_bufsize=78125 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 / pb_ratio=1.30 / aq=0

I mainly use 1-pass encoding high profile 4.1 with crf 20 and without setting preset.

here is what i use

you can edit crf to 20 and then save it to C:\Users\USERNAME\AppData\Local\Meltytech\Shotcut\presets\encode

if its to slow you can try “slower” instead of “slow” preset

quality wise the hyper scaler is way better than anything else, dunno why its not default

Thank you very much for this preset! I’m going to try it and compare with Hybrid encoding.

well am in the same boat, i prefer quality encodes, but by default shotcut presets output okey quality but not high,

btw there is a typo in the preset should be a single rescale=hyper hehe but the preview here is wrong

hey what did you think? got any better?

I have tried to match my Hybrid setting in Shotcut export window but results were not conclusive :frowning:

For example I got a 40¨% bigger file (!) with an equivalent visual result with Shotcut compared to Hybrid. I need to experiment a bit more!

interesting reading: http://slhck.info/video/2017/03/01/rate-control.html

what crf did you use? my profile has 16 :stuck_out_tongue_winking_eye: btw did you try preset=placebo :laughing:

I used crf 20. It seems the size file difference is linked to rate control setting. MediaInfo analysis rather indicates Constant bitrate while I set Average Bitrate (?). So, I will try Quality-based VBR with crf set in Other tab.

mediainfo can be wrong soo you know