Export fails every time (Shotcut 16.11.02 / macOS 10.12.1)

Hello everybody,

this is my second video that I cut with Shotcut. I had no troubles until now. But today I tried to export my video and got a crash-report at the end of report

in English:
Qmelt was terminated unexpectedly.

in German:
qmelt wurde unerwartet beendet.

See details upon.
I got the same failure before I updated to last Shotcut version too.

HELP :frowning:

I can’t post whole description of system-report because to many characters…
Here ist the report on my dropbox:

Here is protokoll-line from Shotcut:

[swscaler @ 0x7f82f88f9800] Warning: data is not aligned! This can lead to a speedloss

I don’t understand. Where is the problem?

This sounds very similar to this report here. Although I don’t think that user was experiencing any crashes…

Nobody is sure what is causing the export errors but the “Data is not aligned!” message is not it.

This user was able to create a workaround by saving their .mlt project and loading it as a clip from “File > Open MLT XML As Clip” and exporting that instead. Tell me if that works for you…

Hi Lauren,

thx for your reply.
I opened mlt-xml-file as clip and tried to export it to mp4.
It doesn’t help. I get the same warning. :frowning:
it breaks after 57% and says the same.


Can you try resetting your video mode to automatic if it already isn’t?
And can you try it with different files too and see if those also produce the error?

Its already automatic. But you’re right. Maybe the problem is different fps, because my video is a mix of clips with fps: 60 & 59,98 & 29,97.
But I just exported another video also with the same different fps. and the export works very well!

The difference to the other project is that the audio track is inserted as a non-cut file. I mean the project, which brings export error has a cut audio track. But I don’t know if that’s the case, because I exported the problem project without audio track and that also brought the same errors.

What is interesting, the export breaks down at about 57-58% and shows the error.

I found the solution. The problem was at 57% of video. There are some JPEGs imported in lower resolution, about 720px. I changed resolution to my video (1920x1080) and it works now :slight_smile: :grinning: :sunglasses:

This is still an issue in the current version, and I tested it on Linux. The debug output on the command line says the qmelt exited with signal 11. Is there somewhere we need to raise this as a bug?

Your problem is probably not the same as the original poster for this thread. I suggest you start a new thread and provide excruciating detail of exactly how you cause the problem. Then, others can try to see if they can also produce the same problem.

Happy to. I assumed it was the same because after I changed the resolution of the photo near the beginning of the video to match the export resolution, it exported fine, just like above. Very repeatable.