Export Failing to Run, Settings?

Log:
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “C:\Program Files\Shotcut\lib\ladspa\AUTHORS”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/COPYING’: “C:\Program Files\Shotcut\lib\ladspa\COPYING”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/readme.txt’: “C:\Program Files\Shotcut\lib\ladspa\readme.txt”:

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 0000000009800140] Statistics: 428183 bytes read, 0 seeks

[producer avformat-novalidate] C:/Video Editing/Intro Clip.mp4

checking VFR: pkt.duration 512

[hevc_amf @ 0000000009809380] AMF initialisation succeeded via D3D11.

[hevc @ 0000000009820d40] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

[hevc @ 0000000009820d40] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

[hevc @ 0000000009820d40] hevc files have exactly one stream

[consumer avformat] Could not write header ‘C:/Video Editing/Costco Chair/Costco Chair 1’

[aac @ 000000000983b280] Qavg: nan

[AVIOContext @ 0000000009800d40] Statistics: 0 seeks, 0 writeouts

You changed Export > Advanced > Format to hevc but that is the incorrect thing to do. hevc is for video-only raw HEVC file that most players and services do not support. That is why the error:
[hevc @ 0000000009820d40] hevc files have exactly one stream
because you tried to include AAC audio:
[aac @ 000000000983b280] Qavg: nan
I suspect you are not advanced and should turn that mode off and simply click Export File to use the defaults, which are good.

Well how rude of you to cast doubts upon my advanced-ness. I wish to use the HEVC format to keep filesizes small. I was able to export using this format and upload to youtube previously. The main thing that changed afaik is that I exported my intro graphic with audio as a separate video and popped that into this new project so I don’t have to re-make that every video.
I thought perhaps because the intro was at 25 fps so I’m trying to redo that part now but that just failed on me.
Log from that:
plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “C:\Program Files\Shotcut\lib\ladspa\AUTHORS”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/COPYING’: “C:\Program Files\Shotcut\lib\ladspa\COPYING”: The specified module could not be found.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/readme.txt’: “C:\Program Files\Shotcut\lib\ladspa\readme.txt”:

[mp3 @ 000000000e0ef9c0] Skipping 0 bytes of junk at 33247.

[mp3 @ 00000000056ff8c0] Skipping 0 bytes of junk at 33247.

[hevc_amf @ 00000000056fd8c0] AMF initialisation succeeded via D3D11.

[mp3 @ 000000000e0ff1c0] Skipping 0 bytes of junk at 33247.

[producer avformat] audio: total_streams 1 max_stream 0 total_channels 2 max_channels 2

[AVIOContext @ 00000000007444c0] Statistics: 131072 bytes read, 1 seeks

[producer avformat-novalidate] C:/Video Editing/Fav Audio Tracks/Harris Heller - Neon Drive.mp3

checking VFR: pkt.duration 0

[filter swresample] 2(stereo) f32le 44100Hz -> 2(stereo) f32le 48000Hz

THREE.WebGLRenderer

THREE.WebGLRenderer: OES_texture_float_linear extension not supported.

[hevc @ 0000000005704980] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

[hevc @ 0000000005704980] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.

[hevc @ 0000000005704980] hevc files have exactly one stream

[consumer avformat] Could not write header ‘C:/Video Editing/New Intro’

[producer avformat-novalidate] C:/Video Editing/Fav Audio Tracks/Harris Heller - Neon Drive.mp3

checking VFR: pkt.duration 1

[aac @ 00000000056fe200] Qavg: nan

[AVIOContext @ 00000000057aa2c0] Statistics: 0 seeks, 0 writeouts

Failed with exit code 1

Repeating the same thing and expecting something different.
I guess you reused the faulty export settings instead of either:

  • click Export > Reset
  • click Export > Default preset
  • restart Shotcut

before clicking Export File again.

You can still use the HEVC codec but do not change the file format to hevc. If you really want to use HEVC, use the HEVC Main Profile preset, which sets Format to mp4.

I do not want to simply use the defaults I want to understand the issue. Before your 2nd more helpful reply I did get a hint. Yes I forgot that I previously used the .mp4 format and figured hevc had to match. I don’t want to simply use the default because I want to understand and optimize, already trying out some tips from research.
So I’m exporting now successfully. While I have your eyes, may I ask why is it that B frames default to 0 but anecdotally I’ve heard other people suggest 2 B frames? Is 2 B frames good for 1080p hevc upscaled to 4k hevc 40 Mbs? Apparently youtube uses a better player for higher bitrate 4k content. This is for my youtube channel.

It does not unless you are using NVIDIA or AMD hardware encoder because most of these do not support B frames with HEVC. You should be able to override that if testing proves it works on your hardware. Otherwise, it defaults to 3 until a preset changes it.

Is 2 B frames good for 1080p hevc upscaled to 4k hevc 40 Mbs?

yes but just a little at that bitrate

Apparently youtube uses a better player for higher bitrate 4k content.

Yes, that seems to be the case as mentioned in this forum several times. A regular user that uploads to YouTube a lot reported only 2.7K is needed. I agree HEVC is a good way to get a smaller file size while keeping the quality up to make uploading faster, especially if you have a NVIDIA RTX 20 series card (or some GTX 16 series cards) and use NVENC to reduce the time to export.

I do have an AMD 5700xt so I’ve been using the hevc_amf codec. Guess that’s why it keeps switching to 0 B frames. How do I test if B frames work on my hardware? About 20% of the GPU gets used during encoding usually. Also is GOP 150 or 300 good for 30FPS?

First, get it working with 0 B frames. Then, go into Export > Codec, change B frames, and try again.

GOP can be as long as you like if you do not check Fixed. But for services like YouTube, it will factor into how they do parallel transcoding to prepare it for streaming and how fast that will go. I do not know their limit before they give up on parallelism or what is optimal for their parallelism. Their guidelines say 15 frames, but that seems even shorter than some optimal value for their system. I take the guidelines with a grain of salt because they handle a very diverse set of inputs. Seems like they had to give some guideline, however, simply to answer the question.

Thanks bud, loved James Spader in secretary btw.