Export failed (19.02.28)


#1

So I’ve been working on this project on and off for two months now, needless to say I’m pretty gutted that it’s not exporting. It reaches relatively high percentages and then fails. I wish I could say I’m tech savvy but I’m really not, so for all I know this project was doomed from the start.

I am using:
Shotcut version 19.02.28
Windows 8

Most of the video files are .AVI. I’ve exported a smaller .AVI clip before without trouble, so I’m hoping that’s not the root cause. I am however using color grading and a second video overlay on each clip involved, and from what I gather that seems to give shotcut fits. This is unfortunate, because the entire reason I downloaded the program was for those two aspects.

I also have tried splitting the project into two smaller pieces and it still fails. As per the advice of one topic, I attempted to uncheck “Parallel Processing”… only to find that option nowhere in my version of shotcut.

Of the multiple times that I have tried to export, I’ve been given different error codes and messages such as:
‘This application has requested the Runtime to terminate it in an unusual way’
Failed with exit code 3
and most recently: Failed with exit code -1073741819

Here is the entire job file, it is quite extensive. I can’t emphasize enough that I have no idea what any of this means.
failure.txt (116.8 KB)

If anyone could help… that’d be rad. I’m really not having a great time.


#2

It should be on the ADVANCED tab of the EXPORT menu

If it isn’t there, you are probably using the 32-bit version.


#3

I guess I’m using the 32-bit version then? which would be really weird because I always make sure to download the 64-bit versions of things. Is there anyway to confirm this one is 32-bit version? And if it really is, is it too late to go back and download the 64-bit? Will I have to restart my project from scratch?


#4

Hit CTRL-ALT-DEL and start Task Manager. 32-bit executables should be identified as such.


#5

Alright so, I went ahead and downloaded the latest version of shotcut making ABSOLUTE SURE that it was 64-bit. There was no change at all. Parallel processing is still missing regardless.


#6

Did you download it from a 64-bit link on the Shotcut website: https://shotcut.org/download/

The logfile you posted has as last few entries:

[producer avformat-novalidate] C:/Users/Gwyn1/Videos/VHS Overlay #4.mp4
    checking VFR: pkt.duration 3008
[h264 @ 000000002f759ac0] Reinit context to 1280x720, pix_fmt: yuv420p
Current Frame:       3507, percentage:         59
Failed with exit code -1073741819

I suspect that at frame 3507 you have introduced the new video clip “VHS Overlay #4.mp4”. It could be there is a problem here. Do you have any filters on this clip and if so can you try switching them off to see if that is the problem?


#7

when%20will%20god%20mercy%20me

yes, this is the link i used.

“VHS Overlay #4.mp4” is actually used throughout the entire video, five different times back to back. each iteration has four identical filters applied:
Opacity
brightness
color grading
and old film: dust


#8

I’ve no idea why you don’t have the option. Maybe someone else can think of why.

You say you have 5 copies of the clip. The error occurred at the 59% (call it 60%) position, which happens to be the very beginning of the 4th clip.

Try disabling the filters fro this clip and see what happens.

Are the parameters for each of the filters on this clip identical to those on the previous clip?

Are they applied in the same order?

f so you could try moving this clip and filters to the beginning and see if the error occurs there now.

If so you could try deleting the clip and recreating it by duplicating one of the others.

If the clips and filters are supposed to be identical, you could check the MLT file to confirm that there are no differences.

One user had a similar problem last week. He was using a FAT32 filesystem instead of NTFS and hitting the 4GB filesize limit that that filesystem imposes.


#9

I HAVE NO IDEA WHAT JUST HAPPENED BUT - i switched around the “VHS Overlay #4.mp4” clip and??? somehow it worked kind of??? it uploaded an old version of the video instead of the one i was trying to save (it was before i added a few more filters) - and i have no IDEA how this is possible but i dont care i’ll take what i can get!! thanks for helping me bro!!


#10

No problem. Your project obviously got to a point where it was a bit messed-up. I’m just glad you/Shotcut managed to get it sorted.