Export Crash Bug (as interlaced SD on v18.06.02)


#1

Export crashes way to often with the latest version of Shotcut version 18.06.02. I am starting pull my hair out over this as it wasn’t happening on previous versions. I am running on Windows 7 Pro 64bit. The crash can happen at 0% but can happen anywhere after that. Windows says msvcrt.dll is the faulty module and the Shotcut Log says “Failed with exit code -1073741819”. I am exporting interlaced SD content in mp4 720 by 576 top field first. Before anyone says that it is a dead format, the only reason that I am so pleased with Shotcut is because it handles field order and resolution correctly, or at least it lets me tell it what is correct. Nero can’t even deal with it’s own captures and I am capturing old home movies. I really love this program, but this bug is making my PC look bad. I thank you for any insight you may offer!


#2

I doubt we can reproduce your problem, but you can provide more details about the export settings.
I just tried using an interlaced DV source clip and using export mp4 defaults except changing Scan Mode to Interlaced, and it worked. Of course, I made a trivial project. You can try to do some diagnosis to determine if this is a problem in your project or something more general.


#3

Actually the interlaced was misleading. It has happened on progressive also. I also think that export settings aren’t likely to be the problem. I get a very similar crash of Shotcut, just by dragging a video to the Timeline. My latest 2 crashes I still have the dump files but I only saved the log from the export failure. Once again I don’t think the cause is obvious as reloading project or retrying the encode often succeed without error. I just get the feeling that something in the new version of Shotcut isn’t playing well with my setup and was hoping to help you with your great product, to make it a bit more compatible. Hopefully by sending the log of the crash or even a dump file, but I haven’t figured out how and when creating the topic I got the impression that I should wait to be asked. Before the latest version of Shotcut, I had never heard of msvcrt.dll as none of Shotcut’s previous crashes referenced that in the Windows Event Viewer. I have now researched msvcrt.dll errors and tried repairing my C+ programs as some suggested that could cause msvcrt.dll errors. That made no difference to this. Since updating Shotcut from March version, I really have been having trouble with these crashes. Before that I knew when to expect issues, but now they happen randomly and often with no effects or filters applied. Thank You for such a quick reply. I know this was my first post and as such thought I would have to wait.


#4

Shotcut is in the middle of a growth period after a couple years with nearly no new major features. There is some inevitable instability or changes in behavior.

v18.03 is probably the most stable, recent version.


#5

I appreciate this and am looking forward to using the new features like key frames and 5.1 sound. I guess that I must just be patient and return to 18.03 in the mean time. I just thought that presenting the development team with an issue might help the team see where things are going wrong, but if you know the issue already, I can see how it wouldn’t help. Thank you for your time and the program.


#6

I am getting the exact same error, Failed with exit code -1073741819, i would really like this to be fixed


#7

If you’re using the latest version, try going back to 18.03 as suggested by Dan above.

https://github.com/mltframework/shotcut/releases/


#9

I think that I found a work around. By installing the 18.03 version with a different name “Shotcut Good” it seems that the 18.06 version works now. At least the encode hasn’t failed since having both installed. I am just wondering if something in Shotcut 18.06 App Data might be missing because they share the same, even with multiple versions installed under different names? I have only been creating the projects in the 18.03 version and then encoding in the 18.06 as I prefer the results. When I updated to 18.06 I had all boxes ticked, so anyone who had the older program files and registry settings boxes blanked may not have the same issues that I had.


#10