Export completed but mp4 not useable

Hi There

i am trying to add several created with iphone and android devices to one video file.

Seems to be working fine, export “completed” with a green mark at the end but the Ubuntu “video” player just shows a still image of the video when opening (jumping to later positions even works, it’s just not actually playing) and VLC only plays video but no audio.
Any clues what i am doing wrong? Some details below… thanks in advance!

  • Shotcut Version number 20.4.12

  • Shotcut Settings

    • Video Mode HD 1080p 30 (also tried 25)
  • Operating System

    • Linux Ubuntu (19.4 afaik)
  • Computer Specifications (In Windows, hit the Windows Key, type “system”, hit enter)

    • Processor. Example: i3-6006U
    • Installed Physical Memory (RAM). 4GB
  • Source File(s) Specifications

    • Codec/Extension types MP4, MOV
    • Resolution: severl ones, vertical and horizontally taken
  • Export File Specifictions

    • Export preset selected: tried default and H.264 High profile
    • Entered Advanced No
    • “Use hardware encoder” checked: No
  • MLT file Save your project to the mlt file, and drag the file into here. 5th.mlt (7.4 KB)

Did you watch all of the Tutorials? Yes/No? Many common questions are answered immediately from the tutorials.

**Did you read the FAQ? (Frequently Answered Questions) Yes

**Did you search the forum for your issue? Yes, but not sure for best search wording[5th.mlt|attachment]

Proper punctuation and grammar. trying my best…

Sorry but unable to reproduce. I doubt anyone will because this works for thousands of people daily. Try playing the video you created in Shotcut. Show the output of mediainfo against the file created.

thanks for your reply!

Playing in Shotcut actually works as exptected!
Mediainfo gives this:

1 Like

You need to show the detailed information. Go to View->Text and post the info displayed.

Complete name : /home/ulli/Videos/5th.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 43.9 MiB
Duration : 1 min 8 s
Overall bit rate mode : Variable
Overall bit rate : 5 407 kb/s
Writing application : Lavf58.29.100

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 4 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1 min 8 s
Bit rate : 5 177 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 30.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.083
Stream size : 42.0 MiB (96%)
Writing library : x264 core 159 r2999 296494a
Encoding settings : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=150 / keyint_min=15 / scenecut=40 / intra_refresh=0 / rc_lookahead=30 / rc=crf / mbtree=1 / crf=23.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Color range : Limited
Transfer characteristics : BT.709
Matrix coefficients : BT.709
Codec configuration box : avcC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 1 min 8 s
Bit rate mode : Variable
Bit rate : 223 kb/s
Maximum bit rate : 384 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 1.81 MiB (4%)
Default : Yes
Alternate group : 1

I cant read any problems out of That… are there any?

Given the information from mediainfo, that video file looks totally fine to me. Do you have any other media players you could try?

It plays fine in Shotcut and mediainfo looks fine. Seems it is a problem with the other media players on the system and not in the video. Maybe their hardware acceleration is malfunctioning (Shotcut does not use it), and maybe a reboot will help. However, I consider this case resolved in context of Shotcut.

Hi All,

thanks for your feedback!
After a lot of forth and back i switched from “gnome” to “ubuntu” and “ubuntu on walyaynd” and on both of the later ones video playing works!

I also tried a little around with hardware decoding (deinstalling vaapi packages) but that seems to have no impact.

THanks for your support and sorry for bothering you with this non-Shotcut topic…


This topic was automatically closed after 90 days. New replies are no longer allowed.