Export can't get past 41%

Hi! I received help here several months ago after trying out Shotcut for the first time and having a frustrating time. Back then, the problem was basically that my computer - a Lenevo Think Pad - is not suitable for making videos. After simplifying my concepts though, I have been able to make videos, even though the app often freezes, crashes, or becomes unresponsive. But as I understood it, my computer simply can’t handle the volume of data transfer sometimes and it gets stuck. There’s nothing to do but close Shotcut and open it again and start from where I last reached.

To date, I have made a dozen videos which I have posted on YouTube, and they range from around 19 minutes to 39 minutes. They all are comprised of a single video track which uses video or stills, and an audio track which may use recorded audio from my iPhone or DSLR, or music files from my iTunes library. While problems regularly occur during the video creation phase, there has been no problem exporting videos other than that it takes a very long time on my computer.

Today I tried to export a 24-minute video but at 39%, the export progressed no further. I tried again but only reached 40%. I resized some of the still photos in order to decrease the data, but I only got to 41%. I restarted the computer and tried again but only reached 41%. For a fifth and final attempt, I cut off the final 8 minutes from the video and tried to export the first two thirds as one video. Once again, 41% was as far I was getting. There is nothing different in this video that any of the others. I am doing the same things as always.

I checked the “job” log and noticed the following.
This part seems to indicate that the exporting is going normally.

[h264 @ 03085ec0] Reinit context to 1920x1088, pix_fmt: yuvj420p

(I used to use a larger video size but then one day my camera kept stopping recording after a few minutes, so I changed to a smaller size. My first Shotcut videos were done with larger files and without export problems.)

This line repeats over and over until…

This part. It seems to indicate a problem with buffering.

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[producer avformat-novalidate] C:/Users/Editor/Videos/Music is a Journey/Episode 10/MVI_4793.MOV checking VFR:pkt.duration 1001
[h264 @ 03086740] Reinit context to 1920x1088, pix_fmt: yuvj420p
[h264 @ 03086b80] Increasing reorder buffer to 1

These lines occur frequently within the steady flow of the first line repeated. Because of “buffer” being mentioned as well as “novalidate”, I wonder if the problem is once again that my computer can’t handle the data flow. If that’s the case, then why was it able to export 12 videos prior, including one of 39 minutes, but can’t export this one of 24 minutes, or even 16 minutes after the video was truncated?

Has something changed within my computer since three weeks ago when I exported my previous video?

Can anyone offer an explanation or suggestions for a course of action? I still have many more videos I hope to produce and some have clips already recorded.

I can’t decipher it for you, I don’t have the expertise, but I can tell you how I solve such issues.

In the logs, take note of the frame number at which it gave up the export. Divide that number by the frame rate you are using and it will give you the point on the timeline where the failure is happening. Check that point on the timeline for anything that seems out of place. If nothing jumps out at me I usually delete the image or clip that’s in that spot, then reload it again and either apply the same effects as before or choose an alternative.
9 times out of 10 that has got me back on track.
Sorry I can’t help with a technical explanation, but I’ll watch this thread to see if anyone else does :slight_smile:

Quinn, that’s an excellent thought! I had first suspected a cluster of photos might be bogging down the process and so I shrank them down. Then I wondered if there was something in the video around the 40% mark that was data-heavy.

I’m off to bed now but I’ll take a look again in the morning and follow your suggestion. I’ll let you know here what the results are. Thanks so much for your advice!

1 Like

So, it seems the problem was happening at the third audio track. The image in the video track was 1000 x 1000, while the image for the previous two audio tracks was 500 x 500. So, I resized the second image, which meant also redoing all the text to go over the image. I tried again and reached 42% before everything ceased once again.

So then I decided to try removing the audio track and setting it in again. This was a huge pest because simply removing it caused all subsequent tracks to shift left but only lifting it out left the filters in place for a non-existent audio file. I also had to select just enough of the original audio file to fill the space available and when I selected two seconds too much and trimmed the excess off, none of the applied filters I put on after - fade in, fade out, gain/volume - would work. So, it took some time to get everything as close to right as possible and get the filters working.

After all this, I tried to export again, but this time the process ceased at 33%, which is about where the first music audio track comes in. During the first seven attempts to export this video, the first and second music tracks were exported. This time, failure.

I am starting to think that I will have to hack this video to pieces and export it section by section and then stitch all the parts together later, if that will work. But I’m running out of my weekend time for doing this and if I have to wait a week, my whole schedule for the remained of 2018 will be affected.

I really can’t understand why I could do this 12 times before using the same format and arrangement and now I can’t.

Hi photopete, sorry I can’t help with a definitive solution but just a thought - perhaps you could try selecting “copy timeline to source” and export sections that way, then reassembling, rather than hacking clips etc from the timeline? Might work, might not - just a thought.

Another thought - if it’s the audio track that’s the problem, if it was me I would try this - open SC and Audacity, play the SC video whilst recording the audio track in Audacity, then export as a WAV (or mp3). Then delete the audio track in SC and re-import the WAV (mp3).

Can you upload the project to google drive(or dropbox?) and someone here might be able to take a look at it?(On a side note the main video editor at my office uses a thinkpad although it’s a P50 workstation)

First, thanks everybody for reading and offering solutions. I am stubbornly impatient when it comes to solving problems like this and so I went ahead and did what I thought to do and my video is now on YouTube. Here was the process:

  1. Problem: Every attempt to export the 24-minute (plus some seconds) video failed. between 39% and 41%, and twice at 33%, the export process simply ceased to proceed.

  2. First remedial attempts: By checking the export log, I found that the problem seemed to be just at the start of the third audio track. My videos always have one video and one audio track, with the audio track used for 30-second samples of songs (used with permission) that are imported from my iTunes library where files were imported with Apple Lossless Encoder. I tried resizing the still photo in the video track (album cover), tried removing the audio track and putting it in again, and tried editing the text boxes that appeared over the album cover image. Nothing helped.

  3. Solution: I opened the mlt file, which was entitled “Episode Ten” and deleted all video and audio clips from the third audio clip and to the end. That left me with just over ten minutes of video. I saved this as “Episode Ten first” and successfully exported it. Next I opened “Episode Ten” and deleted all video and audio from the beginning up to the third audio track. This meant realigning all the remaining audio tracks with their respective video clips. This produced a 13-minute plus video which was saved as “Episode Ten second” and was then exported successfully. Now all I had to do was put the first and second videos into a playlist and encode them together. But…!

  4. A new problem. I found that during my editing of the text in the text boxes of the third audio track’s still image I had made a typo (“in the a disaster”). At first I thought that I’d have to edit the typo in the mlt file and then re-export the whole video, which would take about 90 minutes on my computer. But instead I hit upon this solution. First I opened the “Episode Ten second” file and cut away everything but the audio track with the erroneous grammar in the text box over the image. I corrected the text and saved the 30-second video as “William” because that name was in the song title. Then I selected “new” from the menu and created a playlist, putting the “first” and “second” videos in the playlist. I began playing the second video and hit “O” for “outro” at the frame just before the “William” song was to begin. This short video was placed second in the playlist. I then added the “William” video in third position. Finally, I played the “second” video again and hit “I” for “intro” just at the first frame after the end of the “William” song. This video now sat in position four on the playlist. Now I had “Episode Ten first”, “Episode Ten second” the first couple of minutes, “William”, and “Episode Ten second” continuing from just after “William”. This was my full 24-minute video in the correct sequential order and all parts already exported.

  5. Now I just had to export the playlist. This took 3:39:34 on my computer and when it was done, I finally had my video ready to upload on YouTube. By then it was after 11 pm so I uploaded it this morning.

My computer is lucky to have survived this debacle but as always I learned something new.

Some of the advice given was helpful in the process and I will have to learn about how to “copy timeline to source” for the future because sometimes I need to correct major mistakes and I wish I could save the part that’s okay without having to do surgery on the video like I did this time.

In any case, once again the problem seems to be that my computer cannot handle large volumes of data and the export processes jams and won’t move. I’ll have to do longer videos in at least two parts. It takes more time because I need to export each part, then put them in a playlist and export them again.

What are the specifications of your computer? Operating System? Desktop or Laptop?
What version of Shotcut are you running?
What is your Video Mode set at? (Settings/Video Mode)
What are your source file specifications? (resolution, fps, file type)

Hi Photopete, glad to hear you got it sorted in the end.

Yes indeed - a powerful and useful feature. Enables you to export any section of a video you like without having to delete clips, rename files etc. Just use the blue bar to select which portion of the video you’d like to export. Very useful for testing out short sections of your video without having to export the whole thing.

Hudson555X, thank you for your reply and questions. I’ve gotten past my little hiccough. When I first started using Shotcut, I had a few problems, nearly all of which were related to my computer’s limited capacity for handling large volumes of data. After I changed my approach and understood what was possible, I no longer had any impeding problems. But the other day, suddenly something wouldn’t go. My solution was to split the video into two parts and then put them back together once they had both been encoded. So, all is well for now. Thanks again!

This topic was automatically closed after 90 days. New replies are no longer allowed.