Even with Parallel processing checked CPU never rises above 15-25%

S* hotcut Version: 20.11.28

  • Windows 10 all patches up to date
  • AMD Ryzen 1700 X processor, water cooled. It is not throttling at all. Nice and cool.
  • 64GB RAM. Unless I use a RAM drive, I’m barely using 20GB most of the time.
  • Three SSD’s operational drive is an NVME, with a massive 10TB spinning platter for storage.

I am consistently creating roughly 30 minute videos which use images, text filters, and normally a single video file with splits and overlays, etc.

It doesn’t seem to matter whether I have parallel processing checked or not, - I always leave it checked… But when I compile (for youtube) I am rarely hitting even 30% of the CPU usage. I can shut down programs and leave the entire system completely idle except for that one task and it still won’t climb.

Am I doing something wrong here?

Probably not. Shotcut has not been optimized to be able to use as many CPUs as possible. If you enable parallel processing, it will choose to do more things in parallel. But that will not necessarily use all 16 of your threads.

Hm. Ok. I tried manually setting to 8, 12, and 16 threads with no change. Oddly (to me) not even ONE thread seems to be running at anything like significant effort. It’s like I’m bottlenecked somewhere.

If you are exporting with the YouTube preset, then your output file is MP4 with H.264 video (using libx264). libx264 is capable of saturating your 16 threads if frames are fed fast enough. Maybe one of your filters is bottlenecking threads. Have you tried to open a file and export it without any filters, transitions or a timeline?

If a direct export uses all the threads, then you can try to eliminated one feature at a time until you find the one that is causing the bottleneck.

Brilliant! I’ll give that a check.

This topic was automatically closed after 90 days. New replies are no longer allowed.