Error while exporting to EDL format

Hi there,

First of all, thanks for this great software. So far it really worked well for me:)

However, now I would like to convert my .mlt project to an edl, so my colleague, who works on adobe premiere (and whom I have not been able to convince to switch to shotcut) could open it and further edit my timeline.

But everytime I try to save it as an “mlt” file, I get the following error: “A Javascript error occurred during export.”

I guess this it the corresponding message in the log file:

[Debug  ] <MLT> [producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1
[Error  ] <MainWindow::on_actionExportEDL_triggered> Uncaught exception at line 6978 : "TypeError: Cannot read property 'reel_name' of undefined" 
[Info   ] <MainWindow::showStatusMessage> "A JavaScript error occurred during export." 

The error message appeared both in the windows as in the linux version of shotcut, and I am using the latest version.

However, edl export works well if I try it with a very simple timeline of only 2 clips.

Is there an other way to export a basic timeline (I don’t need special effect etc) to use with Adobe Premiere?

Any help is appreciated as this could save us a great deal of time.

Thanks in advance!

Do you have any still images, image sequences or Shotcut generated clips in your timeline? Or anything else but video and audio clips?

Btw. are you using the most recent version of Shotcut? There was some edl export bugs fixed a couple of versions back.

Please, let us know about your findings, so we can locate this bug. Or else upload a short mlt file where the bug is easy to reproduce.

Hi Tin2Tin,

Thank you for looking into this.

I did not use any stills or image sequentions. If there are Shotcut gererated clips, they might have been added by mistake, but not intentionally.

My Shotcut version is “17.11.07”.

Though I tried, I was not able to reproduce the error in a simple way, but here is an adapted version of the original file. For privacy reasons, some changes were made to the file names by using find&replace in the .mlt file. I did it in such a way as not to change the length of the file names.

adapted.mlt (584.7 KB)

It would be great if you could help me out.


Thanks. Big project you got there. Luckly I was able get the same error as you did without having to exchange all the paths to actual files. However I’m not a coder of Shotcut so I’m not able to figure out on what file/operation the EDL export chokes. I hope one of the Shotcut coders are reading these posts here, if not, we may have to do a proper bug report. But it would be great if we could narrow it down and figure out what element is causing this error first.

The error saying: “TypeError: Cannot read property ‘reel_name’ of undefined” makes me guess that something is in the timeline which is passed as a clip, but isn’t a clip. That’s why I’m asking the questions above, as it may be some (unusual)element which hasn’t been tested against the EDL export code. I can imagine that you’re eager to solve this as fast as possible, so my suggestion to you is to make a copy of your project and clean up the copy from everything not being clean video or audio until hopefully the EDL export succeeds. So no filters, no transitions, no generated clips etc. (Nb. ex. you have a one frame long transition).

Another thing. The EDL format is very limited when it comes to working with several tracks. So when you eventually get Shotcut to export an EDL, you’ll have to open the exported .edl file in Notepad and save each track(called playlist in the file) as an individual .edl file, so you in Premiere can import the tracks one by one.

Found it. In V1 you got a transition at 00:32:39:24 leading to no b-clip. If you remove this transition the EDL export works here.

The odd thing is, that if I make a new project, add a clip, split it, make a transition and delete the last clip, and EDL export still works… So it isn’t just a transition with no b-clip following the transition causing the error. I can’t see from the time line what the transition is transitioning to. It might be some generated clip?

On the track separation workflow, read this pdf:

Another thing is that your cyrillic characters used in one of the audio-files doesn’t come out right. But this is not a reason for the export bug - but it will cause problems when importing from the EDL.
In the exported EDL it looks like this(cyrillic characters replaced with “?”):

  • FROM CLIP NAME: AZIS - Evala _ ??? - ???-385k7GE-e20.wav

Instead of editing the edl file in Notepad to save a file of each track, you can disable all tracks, but one and export that to edl, naming it the track name. And repeat that process manually for all tracks.

The EDL format is limited to one video track and four audio-tracks, but Shotcut does not add track info into the exported edl file.

[For a Shotcut coder: when edl exporting a Shotcut generated clip(add other) eg. a color clip the reel name in the edl becomes the color code ex. 000000 and this can’t be opened on the receiving end. If ‘BL’ is used as reel name, a black clip will be inserted, which is better than nothing(in my eyes). Alternatively, the generated clips would have to be saved to disk as individual files as part of the export process. Maybe the same problem applies to freeze frames of still images?]

Thank you for all the help, tin2tin,

I was able to export the edl-files.

Unfortunately there are problems while importing it to Première. The timecodes are incorrect. But, as far as I understand, that is not a shotcut problem.

All the best!


Make sure that the frame rates(frames pr sec) are the same for the source footage, in Shotcut and in Premiere. And Premiere is not using source file embedded time codes when reading the Edl. Or else things will come out wrong.