Error saving a project file (.mlt)

If you open a project file (.mlt) e.g. by double-clicking and want to save it after editing by clicking on the “Save” button or “file/save”, the error message “An error occurred while saving. Try again!” is displayed. The only way to save the file is to use “file/save as”.

What am I doing wrong?

Is that MLT created with the same version of Shotcut you have now?
On the same computer? Same Operating system?
What type of drive is the project file on? HDD, SSD/NVME, USB, other (what other)?

Here is a sample project created with the current version 22.11.25.
Testing.mlt (1.9 KB)

I tried to duplicate your issue with this simple test project, but it worked fine for me.

If you can provide more information, like perhaps what filters and settings you are changing, I can try to duplicate the issue you are having. It would really help if you could provide a very basic/minimal project that one could easily duplicate.

Hi.

First of all, yes to the first three questions. My project files are located on a NAS (Synology Diskstation DS220J). That seems to be part of my problem. I copied the project file (.mlt) and the movie file (.ts) to a hard drive. And what can I say, it works! I modified the project file and saved it without an error message. Now the question would be why this doesn’t work with my NAS?

This problem (saving a changed project file to NAS) has been reported before, but, so far as I know, no-one has got to the bottom of it. What is clear though is that it isn’t a Shotcut problem per se.

EDIT: I suspect that the Synology DDS thinks that the original project file is still open, hence the rename (mv) will fail. But the file must be closed since otherwise all filesystems, including locally-mounted ones would fail.

In the meantime I’ve made a few attempts. I am now certain that it is a problem with Shotcut.
Case 1: Project file on a NAS
Double-clicking on the project file and immediate saving leads to the error: “An error occurred while saving …”
Case 2: Project file on a local hard drive
The error described in case 1 does not occur.

In the next step I installed the “OpenFilesView” tool. The tool shows currently open files on Windows. I came across a difference that explains the problem and the error message. In case 2, the tool shows me that the project file is open. In case 1 there is no indication that the project file is open.
So there must be a difference in Shotcut whether you open a project file on a NAS or on a local hard drive. Why?