Error Message: Install OpenGL 2.0 or Higher

Please forgive my ineptness in this, I’m not very computer savy. As far as I can tell this issue hasn’t been tackeled in this forum yet. Any suggestions?
I suddenly started getting this message when I try to open Shotcut:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0) .
This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLESv2.dll and d3dcompiler_*.dll) are available in the application executable’s directory or in a location listed in PATH.

Yes, update your display drivers.
Go to device manager, select the Display adapter and choose Update driver.


Unfortunately they are all up to date and I still experience the problem :confused:

What is the model of your Graphics card?

What operating system are you using?

Thanks for getting back to me!
I’ve got a Intel® HD Graphics 4600 and a NVIDIA GeForce GTX 850M
My operating system is Windows 10 Home.

Not being a regular forum user I assume I was correct in adding my query to this posting rather than creating a new subject but correct me if I am wrong, I was wondering if anyone has had any thoughts on my posting yet or whether I should look for alternative software?. Thanks

You seem to be among a small number of people for whom Shotcut does not work with their hardware. Some of those people have found that updating their video drivers helps. But for others it does not. I think your options are to either try different hardware (maybe different video card or different computer) or different software. You can always check back with each new release of Shotcut to see if something has changed that makes it work with your hardware.

Many thanks for your reply Brian, you seem to be doing a lot of the work around there. I had been coming to the conclusion that it must be some deficiency in the graphic card or display adaptor that was the problem but the difficulty is to determine what that is. A reasonable graphics card covers all my work without going to great expense and this was one I was given so I am not aware as yet of its full capabilities but has coped well so far. I could try Shotcut with Linux as I have this as a discrete double boot on that computer but its the same graphics card. I could live without it as the amount of cutting I was to do is small. So I may try another card at some time. Thanks again.

I think that would be worth a try. Your graphics card should have the required capabilities. But for some reason, Shotcut is not able to access those capabilities. If the problem is due to something in the operating system, then maybe it will work in Linux. I would be interested to hear if it does or doesn’t work in Linux.

Looks like @Carlo_Ribaux is in the same boat as me. The odd thing is that when I don’t have my laptop plugged into the dock, it works fine. However, when I do have it plugged into my Dell dock, it will trigger this error. Even though Intel Integrated Graphics is already configured as my default graphics processor, I still have to manually select Intel Integrated graphics for it to work.

If you have all the appropriate NVIDIA drivers installed, you can find this option it by simply right clicking the “Shotcut” icon, clicking “Run with graphics processor” and then finally selecting “Integrated graphics”. It’s confusing, but this works.


Maybe it’s a bug @brian? If you have access to a Dell XPS and a Thunderbolt 3 WD15 hub, it should be easy to reproduce. You can also reproduce it if you right click and purposefully select “High performance NVIDIA processor” too. Never had an application launch on the wrong graphics card, even when the other card is configured as default. Could also potentially just be a bug in how Windows is launching the application (I even rebooted to ensure it wasn’t just a temporary driver bug).

A more permanent fix would be to go back to that right click menu, then choose “Change default graphics processor” and then explicitly define your Intel Integrated graphics card as the default specifically for shotcut.exe. Here’s a screenshot (unfortunately as a new user, I’m banned from two images in a post):

You’re spamming the forum with the same information.

GPU Effects is experimental and can be turned on when opening Shotcut normally.
Not all filters work with GPU and you may experience crashing.

Again, sorry about that. That wasn’t my intention.

Found a solution to this problem.
Actually my Nvidia PCIe card went phut one fine summer afternoon and i was left with Intel G33/G31 gpu. Got this very error every time i tried to execute Shotcut, so hunted the net and bumped into this solution. It is a very simple one, download the following 7z, it contains 32-bit and 64-bit folder containing a file each for required Win OS.

(link removed by moderator to prevent potential problems)

Extract file in main Shotcut folder under Program files.
Shotcut has started working as beautifully as ever.
I am in no way connected with this file, just found it as i was desperate to use Shotcut. Since there was no copywrite notice anywhere, nor any password to extract the file, so I guess it is ok to use this file. Checked for viruses, none found. Please double check guys.
Performance may be affected as your hardware is superior… :slight_smile:
It will help. Just a thought.

I removed your link because it leads to code that is suspicious consider its source (somewhere on a file sharing site). The software you linked to is probably a legit copy of Mesa llvmpipe on GitHub (use the mingw build of opengl32.dll). Doing this overrides any selection of Settings > Display Method and makes it use software, which is reliable but not good peformance for video display.

This issue and above-mentioned Mesa software override is related to this bug report on GitHub:

I don’t think so, the original poster said that Shotcut has suddenly stopped working, so it had been working fine before.

Menu > Settings > Display Method

Besides driver changes outside of Shotcut, the biggest factor affecting this in Shotcut is Settings > Display Method. This was added in version 15.09 and defaulted to Automatic, which selects OpenGL, DirectX, or software as determined by Qt - the library we use for the UI. (This library is also responsible for the presentation and wording of the dialog quoted in the original message.) Which setting works best is very system dependent. On many systems, they all work. Therefore, the selection of a default is difficult. Shotcut does not report information to a cloud service and is therefore unable to determine from analytics data.

In version 17.03, I changed the default Display Method from Automatic to DirectX (ANGLE) in response to numerous problem reports where changing it to DirectX solved the issue.

In version 19.04, I changed it back to Automatic because I added Software (Mesa) option since I upgraded and rebuilt Qt and got it working in both 32- and 64-bit. I wanted to restore the ability for the fresh install experience to be able to fallback to Software (Mesa). Unfortunately, that kind of back-fired. many people again reported problems where changing it to DirectX solved it for them. Also, on one of my systems, Software (Mesa) did not work and gave me the dreaded dialog. This is crazy because the software mode should be foolproof! (But Software should not be default because is slower.)

In version 19.06, I changed it back to DirectX (ANGLE) for the above reasons. Also because I learned that DirectX has a builtin software fallback mode called WARP lending further weight toward making it the default. In this version, I also made a hack to workaround the library limitation and make Software (Mesa) foolproof except if you are running the Microsoft Store app because it is using a technique incompatible with its sandbox mode.

How To Reset Display Method to Default

  • If you are using the Microsoft Store app, you need to reset the app:
    1 - RIght click the app icon and choose More > App Settings…
    2 - Scroll down and click the Reset button (not Repair , the first one) under the Reset section.

  • If you are using the Windows installer, you can run the installer again and on a step near the end, there is a set of checkboxes with options:
    Click to enable the Remove Shotcut Settings from the Registry and continue.

  • If you are using the portable or are comfortable to manually edit the registry:
    1 - start regedit
    2 - navigate to Computer\HKEY_CURRENT_USER\Software\Meltytech\Shotcut
    3 - look for the value opengl and delete it

How To Manually Change Display Method

  • If you are using the Microsoft Store app you must reset the app and choose a different option from above, which will not be possible if the default gives you this error. Then, the only solution is to
    1 - from the menu choose Settings > App Data Directory > Set… and choose a location
    2 - from the menu choose Settings > App Data Directory > Show… to open an Explorer window
    3 - follow the directions below

  • If you have chosen to use an App Data Directory, there will be a registry value named appdatadir that is set, then you need to look for the file shotcut.ini in the specified folder, open it in a text editor, and remove or change the opengl key to one of:

    • 0 for Automatic
    • 15 for DirectX
    • 16 for OpenGL
    • 17 for Software
  • If you are using the portable or are comfortable to manually edit the registry:
    1 - start regedit
    2 - navigate to Computer\HKEY_CURRENT_USER\Software\Meltytech\Shotcut
    3 - look for the value opengl and change it if found or create it as a DWORD with hex value:

    • 0 for Automatic
    • f for DirectX
    • 10 for OpenGL
    • 11 for Software
1 Like