Erratic audio volume keyframe editing


When trying to edit the sound volume, (almost) frame by frame, I’m having difficulties adding keyframes. They also seem to look rather erratic. Is there a limit to the resolution of audio volume keyframe editing?

Thanks for any pointers.

Never saw a curve like that?! The “needle” on the right side without a keyframe there is very odd - no idea how this can happen. If you really want to change audio volume on each frame i wonder what is the purpose behind? Maybe you set too many keyframes too narrow to each other?

I was able to create the needle problem when dragging the keyframes left and right with the mouse. I think the display gets confused because it rounds the position to the nearest frame after the dragging is done

For better control when zoomed in, avoid dragging the keyframes left and right. Also, you can single click select a keyframe and then use the “level” control in the filter panel to set the level with higher precision.

1 Like

It’s a video of a very rapidly rotating carrousel, with four people. The sound should increase each time a person is near the camera. It’s 24fps, hence the sound editing is almost frame by frame, but not quite.

That works perfectly! Many thanks for the suggestion.

You could also try applying the compressor filter. Here are some suggestions to get the settings right:

  • Set the attack and release very low (maybe even 2ms)
  • Set the ratio to 3:1
  • Set the threshold low enough so that the compressor kicks in when the sound is increased. You can see it is working when the “Gain Reduction” meter starts to move to the left.
  • Set the “Makeup Gain” to get the final volume louder again.

Thank you for the suggestion!

I suppose this works fine when the original sound is emanating from the people on the carrousel, but the sound is mixed in from another source.

However, I learned something I might be able to apply in other circumstances. Many thanks!

This problem has been fixed for the next version 21.01

1 Like

Wow, that’s swift! Many thanks.

This topic was automatically closed after 90 days. New replies are no longer allowed.