Edited video is duplicated in the output when exported as MPEG-2

I was going to post this as a bug, but I think it might be a setting I’m missing. The video looks and sounds great but is 3 times longer than original due to being duplicated 3 times. I’m on the latest version and tried multiple times. Has anyone seen this before? Thanks,

Alex

I did some testing around this, and there is not a general bug in this vein. I think you did something wrong. You should do some basic review and troubleshooting. For example, why do you claim it is with MPEG-2 export? That suggests you tried exporting in other ways and did not have the problem. If you did not do that, then you should. When following up, switch to the Export panel, click Zoom Timeline to Fit image and make a screenshot.

Hello! Yes, your assumption is correct. Using other formats it outputs fine. The project is just under an hour long but when using mpeg-2 its 3 hours long (same video duplicated twice end to end). I’m trying to render in mpeg-2 because that is giving me the best quality compared to the raw footage. When using default settings (or any other besides mpeg-2), even at higher quality settings the video has a noticeable blur.

Thank you,

Alex

When using default settings (or any other besides mpeg-2), even at higher quality settings the video has a noticeable blur.

That does not make sense; x264 is an exceptional encoder. And 8 Mbps is not very high for MPEG-2 unless you are using SD (480p). If you are changing resolution in Export > Video you are doing it wrong.

Is Export > Video > Parallel processing turned on? If so try with it off. If that does not help, I suggest to investigate more why the default settings (H.264/AAC MP4) is not good enough quality.

Parallel processing is turned off. I did more digging and found that even after resetting shotcut, video mode was not set to auto. I set it to auto and performed an export without touching anything else and the output came out great. I think I got myself in this situation when converting a clip to vertical video on a prior project done long ago. I noticed my current project was getting exported in vertical format and changed the resolution using the advanced tab instead of video mode. I did not retry mpeg-2 since the video that was just rendered looked great. Thank you again for dedicating time helping me through this issue.

I tried it again using mpeg-2 after setting video mode to auto and it renders now without the duplication. Very strange indeed, but all is well now. :slight_smile:

In the future, you can try to be more clear. When you wrote “duplicate” I think thinking like the video repeated itself: twice the expected duration. If you had said I can see the video on top of itself and shown a frame grab it would be a lot more clear.

It was duplicating its self in the output repeating. (See same video 3 times).

Now you just made it more confusing!

1 Like

Ok…imagine you have a strip of film. You take an identical copy of the film and splice it to the end of the first, then repeat one more time. The finished product is the same footage 3 times back to back. Very long movie with no intermission, lol. Anyways, it’s not happening any more. Many thanks!

Alex