Edit points to music different after export

So I spent 20 minutes filming b-roll around my house for fun today during a rainstorm. Then I spent 7 hours editing that footage together to music, until I considered it good enough for a 5 min video for fun.

After exporting the project and watching the playback of the exported file. I notice that edits I made to the music, on a beat or a music change, no longer line up.

I go back to shotcut and load the project there again after closing it, and all the edit points are good. So I export again, then again, then trying different settings, all with the same result. My first edit in the video on the music (about 30 seconds in) is about 1 second off in the exported file.

So I’m wondering, how can I use this software if the edit points don’t stick?

My project is 1920x1080, 24fps libx264 codec. I’ve tried constant bitrate, I’ve tried quality based vbr (100%), I’ve even tried exporting at 23.98fps to see it that would change anything (it didn’t).

The only thing I can think of is that I have video clips starting 1 sec before the music track starts. Could it be that?? If so that’s annoying.

Anyway, I’ve trying to evaluate if I can use this software for most of my editing, but this is not looking promising. If I can’t trust that my edit points in the project aren’t the same when exported, then what?

Any ideas??

Can you post a screenshot of your timeline? The behaviour you reported is unexpected.

If possible, do make a screen recorder video of when your video playbacks in shotcut Vs when it plays in another media player. That will help in understanding your issue.

There could be multiple factors into why your audio is out of place. I’ve never used 24fps as I’ve only used 60fps for everything. Not saying 24fps is wrong or bad, I just don’t have experience using it. I’m sure many others have.

What version of Shotcut are you using?
What are your computer specs? Operating System?
What are the source video file formats?
What is the format of the music file?
What is the audio bitrate of your project/source music file?

Video file properties 48k bit rate
Audio Sample Rate 2

Project audio project bit rate
Audio Sample Rate 1

I am using the latest version. 18.05.08

Windows 10 home 64 bit
i5-7600k @ 3.8 GHz
about 800 gb of free HD space

Source videos are:
1920 x 1080 24fps H264 MP4 each file’s video bitrate roughly around 24000-27000kbps-ish, 48kHz audio timeclock on those

Music track is a m4a file, audio bitrate is 191kbps sample rate is 44.1kHz, ohhhhh sheeeet, could it be that? I bet that’s it. I guess I’ll have to download Audacity and convert it to 48kHz and try that.

I’ll update later if it works…

On another note. Damn this program crashes a lot! If it wasn’t so quick to restart I’d have given up on it by now.

I was going to do this (screenshot/screen record), but I started having other issues when I attempted it. Some clips lost their gain filters, then crossfades were weird when I attempted to fix that, and trying to go back and fix crossfades/audio behaviors early in the timeline in an almost finished project is frustrating AF. Then after I thought I had fixed those, then I had a clip that’s supposed to fade in, just play as black until the end of the fade in time then jump in abruptly. Holy moly…

The thing that I find so weird about this, is that the project syncs, plays perfectly in the editor, only the rendered file is off.

I’m not sure the difference in frame rate would make a difference.

I had experienced audio sync issues at the beginning of the year. It was a bad update from GeForce Experience. Once I downloaded new Realtek audio drivers it fixed all of my audio issues. Just type “Audio sync issues Windows 10”, and you’ll get the phone book. Took me a month to figure this out.

There is a major update coming as there has been some confirmed bugs with various filters.
Here is a list of fixes for the next update.

I’ve had mismatched audio framerate issues in other programs in the past, sometimes it affected sync, sometimes noise pops or glitching, so I’m going to try that first.

I haven’t had any other issues in any of my other programs, and I do a lot of audio production and editing moreso than video (at least lately).

Thanks for the replies though, and if this works, then it was your questions that led to the D’oh realization.

Will update with results…

My god, every time I think I’ve found the solution, some other odd behavior/bug seems to happen and then the program crashes while I am trying to correct that. UNGH!

Well, the minor update is, since I had to re-edit, I decided to be pickier this time, so it’s taking longer. Plus shotcut crashes about every 15th-20th time I try to move a track around. Luckily it loads quickly and the auto-save files usually seem good.

The other issue I’m dealing with, is that this is a video edited to music. And the damn waveform graphic is inconsistent and often unreliable. Every time I do an edit, I click on rebuild audio waveform to hopefully make sure I’m seeing an accurate representation of where the beats are.

I will check in later to report on how the export goes…

There was a problem found with some audio mp4s that was fixed recently for the next release.

I don’t think that’s the same issue.

In my case, the music file played correctly in the editor, but in the render, my edit points were slightly to 1 second off.

I believe the problem was – I had 48khz project and audio from video files, but the m4a was 44.1khz.

The composer send me an export of the music at 48khz, and the sync issue was fixed in subsequent renders.

So if it’s fine in Shotcut, the question is which media player are you using? Have you tried other media players?

In the original project timeline, the edits were synced with the music.

After exporting, the exported file’s edits were slightly to up to 1 second off with the music. I tried it in VLC, WMP, and bringing the exported clip back into shotcut, and the results were the same across all three.

I did a re-edit of the original project, but replaced the 44.1khz music file with a 48khz version, and it fixed the problem in subsequent exports.

Moral of the story, don’t try to use a 44.1khz music file with video clips that have 48khz audio, or project settings that are 48khz.

Not sure if that exactly qualifies as a bug, or just a quirk. I’ve had similar (not exactly the same, but glitchy) issues in the past in some audio editing programs when mixing 44.1/48khz