Edit errors trimming a clip

Well, I think it’s a bug.

I’m working with a clip that’s a transfer from film (done professionally). There are five shots in the clip, separated by the original cement splices. When I add the clip to the time line and then remove the few frames that are damaged by the splices, everything looks correct. When the video is exported, junk appears where I’ve trimmed. Not necessarily the frames I trimmed. Usually I get three or four frames from elsewhere in the clip. (That is, not necessarily the handles on the shot I trimmed.)

I’ve used other portions of this same film transfer doing the same cleaning up without any trouble.

I’ve even cut just this clip and exported it lossless. Same problem! If I clean up that export, then I finally get clean edits. But lossless isn’t quite lossless and I shouldn’t need to do this. Not to mention that this also creates an aspect ratio problem.

Any ideas about what is going on?

I’ve tried importing each of the shots separately as well as trying to edit the whole clip. The errors aren’t exactly the same, but they’re still errors.

Aside from telling us about the trouble you’ve had;

  1. You haven’t told use anything useful about the source files.
  2. You haven’t told us which operating system you are using or anything about your PC
  3. You haven’t told us anything about which version of Shotcut you are referring to.
  4. You haven’t told us anything about the Shotcut export and encoding settings you have selected.

PS: Posting a sample showing the ‘junk’ could also be useful.

1 – The source file is a ProResHQ.mov file. The transfer is from 16mm to digital. Transfer house transferred silent speed film to 16:9 @ 23.9 frames, which is not the most helpful thing they could have done. I have used many other clips from this same transfer without the problem. I am respeeding at .66. Color grading and cropping don’t seem to change the result as I’ve tried export with and without.
2 - W10 Pro – i5 4 gb
3 - 17-11-07
4 - H264baseline or lossless h.264

A bit more detail.

The clip I’m trying to edit consists of 5 shots following a title:

What I want is:

That’s what I see when I run the edited material as the Project in Shotcut.

What I’m getting when I export it is (lower case are the frames that aren’t supposed to be there)
/title (12 fr) / A / b (12 fr) / C / B / c (11 fr) /D /e (2 fr) / E/

This is its own separate file. The only other clip is a brief piece of 4:3 video at the start to set the aspect ratio.

As I’ve noted, I’ve used other sections of the source file without any of this trouble.