Drag and drop source video from external hard drive not working


Drag and drop of source video from external hard drive (D:)
onto ShotCut does not work,

Drag and drop from internal main operating system hard drive (C:)
onto ShotCut does work fine.

Win 10

Any ideas on what I can do to get source videos to drop from D: too?


Interesting. I’m running Linux and Shotcut doesn’t seem to know about my secondary HDD. So, I drag and drop, which works perfectly. Hmmmm…


Are you testing this with the same file on either drive? Clip A from the C: drive, and a copy of Clip A from the D: drive? Or have you only tried with different clips?

(multiple drives also seems to be working for me, with 18.03.06 on Win8.)

Do you have a specific set of steps that you’ve used to test both drives individually? (i.e. “start shotcut, drag file onto Preview pane.”)

External as in removable? If that’s the case it’s probably for the best that it doesn’t work because Shotcut won’t be able to access the file when you next load up your project with the drive disconnected. Files aren’t imported, just linked to in the .mlt file so you’d be better off grouping everything together in its own project folder on the internal drive for future reference.

I work from external HDDs all the time. It’s never been an issue. I’ve even worked directly from SD cards.

Me too. I used files on an SD card to create a project. Some days later I opened the project but forgot that I’d unmounted the SD card. Shotcut warned me about the missing files. I closed the project, inserted the SD card and opened the project et voila! All was as it should be.

Thanks for the ideas.

I have a 1 TB external hard drive, always connected to computer.
I have an .avi on C: and a copy of the .avi on D: (the external HD)
I start ShotCut, then view> Restore Default Layout (that step probably does not matter)
Then I drag the .avi from C: and I see the plus sign as I drag it over ShotCut.

…okay, here’s something I just noticed…If I drag the .avi over ShotCut from Windows Explorer folder D: it does not show the plus sign and thus will not drop onto ShotCut…whereas as if I drag the same .avi on D:from a search tool called Everything it does show a plus sign over ShotCut and the .avi does drop successfully onto ShotCut.

So now I’m wondering why the .avi on external HD D: will successfully drag and drop into ShotCut from a search tool I use to find the .avi, but the same exact .avi (not a duplicate, not a copy) will not drag and drop from the Windows Explorer folder onto ShotCut.

Thanks for any other ideas to try.

_Edit: (this part is not accurate)
Okay, here’s the problem.
I was running ShotCut as administrator.
ShotCut.exe> right click> properties> compatability>
Run this program as an administrator.
Now with that unchecked, I can drag and drop source videos
onto ShotCut and they load fine.
Thanks for the ideas.

Edit: Whoops, sorry, that part above about not running ShotCut as administrator is_not_ the solution either. I posted too soon about that.

What happens is when I right click on the .avi from D: and use Send To>ShotCut, the .avi will load into a new instance of ShotCut. That new instance (which received the .avi by way of right click on the .avi> Send To> ShotCut) will indeed accept a drag and drop from Windows Explorer folder D: Why it allows drag and drop only after doing the Send To I do not know.

So anyways, there’s some info, some things to consider. I tried to present all the attempts I used.

My goal here is to be able to just go to a folder on external HD D: and drag and drop a source video onto ShotCut.

Thanks for any other ideas to try.

Okay, here’s my workaround for now.
Start a new ShotCut project by right clicking a source video file on D: and using Send To> ShotCut.
Then when that video loads, in ShotCut playlist click the plus sign to have the loaded video show up in ShotCut playlist.
From then on just drag and drop any additional source videos into Playlist area.

Sorry if all this was way tedious and long. Was trying to be thorough to perhaps help me get a solution to the problem of not being able to simply drag and drop a source video from my external HD here (which is always plugged into computer).


Odd, I have three external drives always plugged in and always worked from them, I have no video files on the SSD boot drive and never work with resources located/stored there.
Shotcut doesn’t need running as admin, it’s perfectly compatible with W10.

Sounds like something peculiar to your machine. Perhaps some drive monitoring software?

No drive monitoring software that I know of.

I guess my question now is why after a Send To from D: does this “Send To opened instance Shotcut” now accept any drag and drop from D:?

If I start Shotcut normally, clicking on the .exe, it will not accept drag and drop from D:

If I start Shotcut by using Send To, this instance of Shotcut will load the source video and then accept any additional drag and drop.

With the Send To instance still opened, I start another instance of Shotcut normally and this normally opened Shotcut will still not accept drag and drop.

If I close both instances of Shotcut and then reopen the saved Shotcut project file that was opened with Send To, this time opening it by just clicking on the .mlt project file, it will accept additional drag and drops from D:

So now I’m wondering, what is it about the Send To that is making Shotcut here accept drag and drops from D;, with normally opened instances of Shotcut still not accepting drag and drop.

Thanks for any other ideas to try.

I think I found the problem.

I was using an older version of a launcher called Keypirinha to start Shotcut.
Whenever I started Shotcut using this method,
Shotcut would not accept drag and drop from D:
I updated Keypirinha, and now when I start Shotcut with it,
Shotcut accepts drag and drop from D:
Well, rebooted and now no drag drop opening in this way.
I submitted a bug report there…maybe it will get fixed somehow,
or maybe it’s something else altogether. I’ll report back if a clear solution
comes about.

So, a bit of a mystery to me, but now it’s all working fine.

The part that’s a bit intriguing is that something is going on it seems when Shotcut is started, where depending on how it’s started, that may be a factor in determining whether or not Shotcut will accept drag and drop from external HDs in some cases.

Well, for anyone else who ever encounters this kind of situation, maybe they can explore various ways of starting Shotcut.

Thanks for the help and ideas.

It has to be something you’ve missed about your system if it works just fine for others [myself included] from external HDDs and even SD card readers.
Something you have running which you’ve forgotten about. Perhaps you could restart Window10 in Safe mode (Hold SHIFT while pressing Restart) and see if the issue persists.

Okay, I tried safe mode, but still the Keypirinha launcher way of starting Shotcut makes Shotcut not accept drag and drop from D:. So, no problem really. I will just not use this launcher for Shotcut. I let them know about this issue at Keypirinha bug report site. So thanks for all the ideas. Much appreciated. Looking forward to enjoying Shotcut. I love that is has so many video filters now. Haven’t used it for months. Back then not sure if it had all the filters it has now to play with.
Thanks again.