Doubts about the TP value in the loudness meter


#1

In the loudness meter, the TP (True Peak) value indicates a positive value (728.5 dBTP) outside the scale range (-50 to +3)

xwnFw5ZF0O

This value seems strange, so I did an analysis in DAW with a VST plugin (Youlean Loudness Meter 2) resulting in a True Peak value of +0.5 dB.


Why is this value so high in the Shotcut loudness meter?
I suppose that the loudness meter in Shotcut uses EBU R128 so I do not understand the TP measurement difference between both meters.
Additionally, I contrasted with another VST meter (TBProAudio dp Meter III) and the TP value (+0.4 dBTP) does not match with Shotcut.
Bdegg84nS9


#2

57%20PM
That is very, very high, never seen that before.
I normally aim for -1.0 as an absolute max.
Since you posting this, I tried to get similar strange results from my SC and nothing.
Applied 2 X Gain/Volume filters to the same clip and the worst I got was +3dBTP


#3

I have never seen that either. I can not reproduce this with any of my sources.

@ejmillan do you have a short clip that you can share to reproduce the problem? That would be helpful for me to fix it.


#4

I made new tests:
I extracted the audio in Audacity and export it to WAV and mp3 format.
Dragging the WAV audio file over the timeline creates a video track (video + audio).In the first seconds, the TP value goes up to 766.7 dBTP.
Going back to the start point of the video also causes the TP value to go up.


The same goes for the audio track in mp3 format.
Additionally, I tried mute audio on the track.
The error in the TP value persists.
The rest of the loudness values do not vary because the audio is muted.

However, when I create an audio track and put the audio in it, there is no problem with TP.
I see that TP represents momentary values (not maximum value)

The last test was importing the video (video + audio). The error in TP is the same.
There is a moment when the TP value has an exaggerated rise and is blocked (although, as we saw above, it is a momentary measure that should continue showing values)
I also checked that this does not always happen. Here, the TP measurement behaves correctly.


#5

Here is the link to the mp3 audio file with which I caused this failure.
https://drive.google.com/file/d/1xIoCUe0WWoYIWslg9-9nR8Chzy0NbDoW/view?usp=sharing

Value TP 728.5 dBTP with Shotcut 19.04.21
Value TP 766.7 dBTP with Shotcut 19.04.30

I have tried other source videos and had no problem with the True Peak meter.


#6

Interesting.
I tried the same tests as you with your mp3 file and in all cases the TP were sensible values.
Running SC 19.02.20, I see you have newer versions.
Perhaps something got broken in later releases?


#7

After doing what I show below, it seems that now works well.

I do not know if both problems are related.


#8

The measurement error of the dbTP value appears and I still haven’t been able to relate the reason.
What I know is that once the error appears, if I save the project (.mlt), every time I open the file this error appears.
Today I opened a project in which the media files no longer existed.
Still, every time I played the project, the dbTP measurement was wrong.
Then, I removed all the content from the timeline, as well as the entire playlist.
The error persists.

Attached project .mlt file (empty project) as well as project log .txt file.

dBTP 770.6 error.mlt (3.8 KB)
dBTP 770.6 error.txt (32.8 KB)

I hope this helps identify the problem.


#9

Does the problem still occur if you disable Settings->Realtime (Frame dropping)?


#10

I tried to reproduce today the problem with dBTP but it doesn’t happen. :sweat:
Not even with the above-shared project.
Until now, when this bug appears, closing Shotcut and reopening it doesn’t work.
So what I do is:
I close SC - I open SC- I open a different (existing) project (B) - I close the project (B) - I open the project I want to edit (A)
This somehow resets something and the problem doesn’t appear during that project edition (A).
Another way is to restart the PC.
When I get to play this issue I will try your solution and report the result.
Thank you very much.