DNxHR HQ export preset is available

I’ve created a DNxHR HQ export preset for anyone seeking an alternative to ProRes for high-quality intermediate multi-generation encoding. The advantages compared to ProRes are:

  • File size is only 64% of an equivalent ProRes file
  • Encoding takes 44% less time than ProRes

Picture quality is visually lossless, equal to ProRes HQ. The time and space reductions happen because DNxHR HQ is 8-bit whereas ProRes is 10-bit. However, Shotcut is currently 8-bit, so time and space are wasted by ProRes as it stores 10-bit numbers whose true versatility won’t even be used. DNxHR is a perfect complement to Shotcut’s output, and is already used by the “better”-quality setting of the “Convert to Edit-Friendly” feature. (EDIT: I said “max-quality” earlier by mistake… I was typing while looking at something else.)

To use the export preset, copy the file below into this folder (on a Windows system) and rename it to remove the .txt extension:
C:\Program Files\Shotcut\share\mlt\presets\consumer\avformat\intermediate

Then find the preset in the Export panel under intermediate > DNxHR HQ

DNxHR-HQ.txt (292 Bytes)


Does this have the same settings as the DNxHR from “Convert to Edit-Friendly” except with PCM audio instead of ALAC?

Correct. Both are the HQ profile of DNxHR, and my preset uses pcm_s24le instead of ALAC for audio. I could be easily convinced to go back to ALAC if needed.


I just gave it try…under Linux. But it should be the “same”. The folders are identical.
Howsoever, I have now an entry “DNxHR-HQ” under “Intermediate”…
But the result is a white screen with only music/sound. :frowning:
BTW: The exported file size is 9,9 MiB…

Any suggestions? :slight_smile:

Best regards

That’s odd. Unfortunately, I don’t have a Linux box around to test it. I’ve got some hardware I could build up into a Mint box and give it a try several days from now, but I guess Convert to Edit-Friendly is the workaround in the meantime.

Thanks, no problem!
Had it already done that way:
Export at 85%: 833MiB
Userfriendly DNxHR-HQ: 11,2 GB :slight_smile:
Userfriendly H.264/AC-3 : 1,5 GB

I’m looking forward to your export preset.

Best regards
'Til then

The Windows path I referenced is the Shotcut “system” area. Export presets can also be stored in a user’s profile in their home directory. What happens if you put the DNxHR preset in there instead of the system area? This post might help locate where the user preset area is on your distro. If you find the “presets” folder under your home directory, there should be another directory under it called “encode” where custom export settings can go.

Sorry for asking: You mean me?
If so, I always use the portable tar file… And that (and the extracted folder) is stored in my “Personal Folder” -> “Downloads” - > “Shotcut”…

Where could I find a folder “encode”?


The presets folders are created here. You have to create a custom export preset in SC first. Then an encode folder will be created.


@Earlybite To confirm, did you rename the file to remove the “.txt” extension after putting it in that folder?

@sauron Would you be willing to try an export with that preset and see if you also get a white screen?

It looks like this:

The path is:

Just exported a 48 second sequence with your preset. File size came to 1.04 GB. No white screen. Picture quality perfect.

You did it right. I’m not sure what to tell you until I get a Linux box back up. Have you tried the AppImage version of Shotcut and then put the export preset in the user encode folder that @sauron described?

@sauron, thank you very much for the test results. Helps a lot.

This preset will be included in the next version 20.02

My first test was with Windows.
Just did a test with Linux. Same clip. No video, audio only. File size is 2 MB.:frowning:

The DNxHR HQ file I used with Linux was copied and pasted from Windows. When I looked at the advanced export tab the format was set to mp4, codec libx264, audio aac.

Rewrote the file using Kwrite. Now DNxHR HQ works. Used the same clip. Video and audio played. File size was 1.0 GB.

@Earlybite try this file.

DNxHR-HQ Linux.txt (277 Bytes)

Looks like the Linux version is not happy with the CR+LF after each line.
Only wants a LF (new line).

Good call @sauron


I assume if I wanted interlaced, would have to change the line:
progressive=1 to progressive=0 ?
What about field order?

@shotcut Thanks for the inclusion! @sauron’s file would need to be used instead (stripped carriage returns). I defer to your preferences as far as PCM vs ALAC. I get the impression you want to support the potential of 32-bit audio source files, and ALAC would be necessary for that. I chose PCM for decoding speed and to guarantee there was no conversion alteration from 24-bit DAW output to 32-bit ALAC. But I have no strong burden either way.

@sauron Great catch. Thanks for figuring it out!

@Paul2 Yes, switch to progressive=0. Then add top_field_first=1 for TFF or top_field_first=0 for BFF. I didn’t make the preset interlaced because it would be a 50/50 chance of guessing which field order the user needed.

I already converted to LF only when I committed it.

The preset only sets the controls that you can override in Export > Video.

Yes, it works!
I copied Timeline to Source, selected 17 sec. to test and gave it a Go.
Export Time: 53 sec. (Intel I3-6100, 2 Cores / 4 Threads, 3,7 GHz)
Size: 913 MiB
Quality: Excellent

BTW: When I removed the file type ending (.txt) then it was, of course, ‘DNxHR-HQ Linux’, but it was shown in the export panel as ‘DNxHR-HQ’. I then renamed ‘DNxHR-HQ Linux’ to ‘DNxHR-HQ’ and all is fine.

@Austin @sauron
Thanks for your efforts and
best regards

Thanks for the confirmation.

Perfect, thanks.