Disable Ripple Editing entirely?

How do I disable Ripple Editing entirely? I’m trying to Cut and Paste clips around my timeline, but it’s rippling everything no matter what I set Ctrl+R to. I don’t really like Ripple editing and would prefer to work without it unless I choose to.

Just click to turn them off.

Also same as this post.

Thanks but that doesn’t work, which is why I specified trying Ctrl+R.

I was able to trick the program by Hiding the track I wanted to stop rippling and then moving the clips around, that seems to keep the clips from Rippling.

Do you mean you can’t get the buttons to turn off?

They turn on and off, but CTRL+X still makes the track in question Ripple.

It seems you misunderstand the difference between Ripple and Ripple All Tracks. Also, hiding a track does not affect the behavior, but locking does.

Dunno, I’m just telling you what my experience seems to be. I have both Ripples turned off, and Ctrl+X makes all my clips shift out of place. When I Hide the track (Not Lock), it does not shift the clips.

Certain keyboard shortcuts always ripple including cut and paste. If you do not want that, do not use that keyboard shortcut. There are others including lift, copy, and overwrite.

Ok, so there’s no way to disable Ripple. That’s all I needed to know, thank you.

What about Ctrl+Z instead of Ctrl+X ?

Alright, I tried Z (lift) which takes up the clip I want to move without a Ripple, but I can’t find anything that drops it back at the Playhead at the same length it was before? R seems to fill whatever space it’s given.

Found it in B. So Z and B are like Cut & Paste without Ripple. Got it.

I was about to mention B :wink:

Lift does not copy.

Thanks for the help everyone. I’m liking Shotcut so far. It’s a bit of a hurdle coming off Premiere, but I’m grateful for the work you’re doing with this and it’s an exceptional replacement for impoverished janks like myself.

Okay. I guess I don’t understand still. I really just want to be able to move clips, but none of this is making any sense.

So… C then Z then move playhead then B

1 Like

Just curious. Any particular reason why Z doesn’t copy the clip ?

Because that is not the definition of Lift as established in the non-linear editing paradigm. Also, sometimes, you do not want to overwrite what is in Source. It would stink that every time you remove (Backspace and Delete when not using Shift are aliases for Lift) Source gets changed. Maybe there can be a Copy+Lift or non-rippling Cut added.


Sounds like a winner.