Deleted V1 now can't get compositing to work

Don’t know if this is a bug or just me having done something stoopid? (Stoopid monkey!)

Earlier today I tried 18.07 for the first time, intending to add a little extra key-framed rotation animation to a project that I’d put to one side ready for the July update - a finishing touch. I encountered the jittery sound bug, and with the amount of effects I use in my work, it sounded like daleks on mogadon - totally impractical for me to work on syncing sound effects to animated objects. Once I realised that the sound problem was one I shared with others after reading the relevant thread in these very pages, I closed SC down ready to go back to the previous version, but I reflexively clicked “yes” on the “save project before closing” dialogue.
Now I’ve loaded the same file into 18.06.02, two odd things have happened:

1. My playlist (which I use alot) has done a runner! It was empty when I reopened the file in 18.06.02 (there are 3 items in it now after trying to repair it)

2. Track V1 no longer composites with the rest of the video. All the symbols on the track margins are correct, the properties of each track are fine, I’ve tried rebuilding V1 with new files, but the result is the same. All the compositing on tracks V2-V10 works as it should if V1 is not displayed, but if V1 is on it displays on top of tracks V2-V10.

During the process of trying to make it work, I copied the contents of V1 to a different track and removed the empty track V1 in the hope it might change something in my favour, but it made no difference.

I don’t want to have to rebuild the whole project again if I can avoid it, so I’m hoping there’s an edit I can apply to the MLT that might reset the compositing back to normal. I can live without the playlist at this point because apart from a few small edits the video is complete.

Can any of you guys work out what I need to do?

SQ_CSO_01.mlt (226.7 KB)

Win 10 pro
AMD FX processor
16GB Ram

This might be too simplistic.

Have you tried using the Windows restore previous versions function to restore a copy of the mlt from a few hours or days before your last save?

If only it WERE so simple. My installation of Windows 10 (completely legit) has never allowed the restore function to work properly. I cannot restore old/deleted files in that manner.

Tried Shadow Explorer?

The restore function seems to depend on the system protection function.

I’ve found that every time a Windows “feature update” is installed, system protection gets disabled. I’ve had to manually enable and configure system protection for it to start working, and for the restore function to start working again.

Thanks for the suggestions guys, but no dice I’m afraid. No restore points and no shadow copies for Shadow Explorer to find :frowning: I must admit I didn’t realise the restore functions were getting turned off after Windows feature updates. Might explain why, on the odd occasions I’ve looked at the settings they’ve been turned off when I could have sworn I’d turned them on previously.

Guess I’m back to repairing or recreating the project.

In your .mlt file, locate all <transition> that have <property name="mlt_service">frei0r.cairoblend</property>. All of them (except V1, which has b_track=1) should have a_track = 1, but they are 0 in yours. Only V1 should have a_track=0 and b_track=1. It appears there is a bug when deleting V1 that caused this.

1 Like

I fixed this delete V1 track bug for next release v18.08.

1 Like

Thanks for the advice and the fix Dan. You are a star :smiley: