Deinterlacing

I have some 1080i material that is shaky and noisy. So I am using Stabilization and HQDN3D and it works good on some material and not so good on more interlaced material.

I have played with filters order and I don’t see much difference : garbage in - garbage out.

Is there a way I could force Shotcut deinterlace material before feeding it to HQDN3D?

How does Shotcut determines if timeline is progressive or interlaced exactly?

Would dropping 1080i clip on 59.94 timeline force Shotcut to deinterlace before applying any other filters or am I way off with this idea?

Figured out progressive=0/1 property of profile in .mlt. Would setting progressive=1 force Shotcut to deinterlace 1080i before any other filter is applied?

After playing a bit more… In my experience it doesn’t sometimes (assuming that setting progressive=1 on profile makes Shotcut deinterlace prior to any other filter). When rendering an .mlt with profile with progressive=1 Shotcut resets it back to progressive=0… definitely when I drop an interlaced .mlt on a timeline, but sometimes it treats timeline as progressive=1. What is expected behavior here? How does Shotcut figures out if timeline is progressive or interlaced?

What deinterlacer does Shotcut use exactly?