Deinterlace before filters

It is said that Shotcut deinterlaces video before filters. It is defined in loader.ini:

# This file defines the normalisers, their fallbacks and the order they're attached
# The names on the left are arbitrary, but the order in which they occur is the
# order in which they're applied.
# The names of the services on the right dictate the preference used (if unavailable
# the second and third are applied as applicable).

# image filters

# audio filters

The problem is, that I still see interlaced video. Deinterlacing on export is not an option because resize filter is also needed for me.
What to do to get correctly deinterlaced video?
Here is a screenshot of what I see:

I advise you to convert the video to the correct format for editing.
Activate the deinterlacing filter in the converter settings.

OK, thanks!

Looks like I need advice to use some other app. Some batch processing video app.
I have 115 files I need to correct.
Currently the source videos are interlaced 720x576px 1:1 pixel aspect ratio. They are narrower than supposed.
Finally I need corrected width to height, 960x720px progressive 1:1 par.
I need to upscale because youtube does not support 576p and downscales it to 480p which makes these old videos even more low rez.

Of the free encoders, I recommend “HandBrake”. It is very easy to set up.

I just played with handbrake. Upscale is not possible in GUI. Only command line.
I’ll check how hard it is to use command line.
At least it suppors NVidia encode. I have very powerful GPU.

Maybe Shotcut is not detecting that your source material is interlaced. Can you share a screenshot of the properties panel for your clip?

That’s it. I manually set it from progressive to interlaced under the file properties in ShotCut. Now the ShotCut deinterlaces it.
The problem is solved.

This topic was automatically closed after 90 days. New replies are no longer allowed.