Default to Custom Layout

I see something like this has been raised before so I’m not sure if this is a bug or something I don’t have quite right.

Only a small thing but Shotcut won’t default to my custom Layout. Currently every time I go to edit a video I have to use the shortcut key I have assigned to my layout. The layout is basically similar to the default, no panes moved but resized to suit me better. Not a big deal but a bit of a pain. I am using v23.07.09 running on Linux (Debian).


I can never reproduce it. Try this:

  1. Start Shotcut
  2. Choose a custom layout from the menu
  3. Do not open a project or any media
  4. Restart Shotcut

Is it using close to your custom layout now? Notice I said “close” because it seems it is not perfectly pixel accurate for the size of everything.

No, still the same. Interestingly if I move and resize a pane it brings that back correctly but the main pane, timeline etc still default back to the base size.

Well I don’t pretend to understand why but I seem to have fixed the problem. I changed Shotcut from full screen to Window, selected my custom layout & then changed back to full screen. The layout stayed (as expected). I then closed Shotcut, restarted it and my custom layout was selected. I’ve since closed & opened it several times, rebooted, tried different layouts including the defaults, gone back to my custom layout & every time the last used layout has been displayed. Happy days!

1 Like

Strange, I never knew the intended behaviour was for the selected layout to remain after a restart, mine has always reset back to default.

I just tried your solution as well and it hasn’t worked, so no idea what’s going on. I’ve had this issue on two PCs now, one on Windows 10 and Windows 11.

This topic was automatically closed after 90 days. New replies are no longer allowed.