Debian 9 Custom Build Missing Requirements

I “roll my own” Debian w/ Mate. It’s my own script based build and ultra slimmed down with no additional packages installed. I can do everything I need to do except edit video - and I desperately want to use Shotcut…

I’ve tried in the past to get Shotcut to work, and it was loaded with missing package errors (more than just gstreamer) due to the lightweight build. As a workaround I’m dual-booting ‘windows’ with Premiere. I don’t like either - at all. We’re an open source / *nix only family (I’m a server guy) and I don’t like breaking tradition just to edit videos… Premiere has finally pis**d me off enough (complicated does not equal better) to want to solve Shotcut on Debian.

‘windows’ wouldn’t even be in this house if it weren’t for issues editing video (editing with gpu acceleration, stabilization, color grading, key-frames - I’m not talking about OpenShot style simple editing).

From memory I think I was missing mlt, ffmpeg and gstreamer. If I remember right I had issues rolling back gstreamer from the Deb 9 repo - I think it was 1.1 and I needed 1.0… There was a list on the download page that listed packages - I followed that and still couldn’t get it working.

So my three questions are:

  1. Is there a standalone that already has the missing packages at the correct version (would solve rollback issue). I did try the portable version last time to no avail - that was probably over 6 months ago, so maybe it’s changed?

  2. Is there a way to turn on debug or a much more verbose output that will tell me specific packages and their versions I’m missing to standard out? I turned on verbosity last time and it didn’t help to identify - so I’m asking about something more verbose than that, like debug or a stack trace. I don’t really want to deal with dependency building this way.

  3. Is there a tutorial that will list the packages and point to their correct versions, preferably in .deb form (vs adding repos)? Or, better yet - a script that would check versions and pull them from a github or similar? I would prefer this method. In fact, I think I remember some site that had a blueish/purple background that tried to list requirements - I followed that too, but I was missing more than what it called for.

Note that the last time I tried, I was able to get the program up. From memory, there were issues with missing icons (yes, I use my own icon set) so the interface didn’t look right (non-issue, I can fix it) and I couldn’t get stabilize to work (that is an issue, yes, ffmpeg was installed). The biggest problem was that there were still tons of errors on the back end - that broke my confidence… I want to feel very confident as these are more than just moving images - they’re our memories.

I’m sold on Shotcut… …and would prefer to just have a list of what to install vs the “needle in a haystack / throw everything at it” process I used to try to get it half-working last time - along with no significant errors on the backend.

…so I haven’t tried installing it again as I’m obviously wanting to “install and go” thereby avoiding the same hassle - which means I don’t have a log for you.

-> Lastly, thank you to the devs and the mlt guy - you’re fixing what keeps *nix desktops from the mainstream and making the world a better place!

Thanks in advance to all who put effort into their replies!

The official files offered for download include almost all the dependencies you could possibly need:

These are the preferred installation form and the only packages that are supported on this forum. If you choose not to use these packages, please don’t come on this forum to ask for support help if you have problems. It’s nothing personal - we just don’t have volunteers to support every arbitrary package on the planet. We do accept patches from people that are self-supporting their own builds.

The standard output includes some hints about missing dependencies - but not all. YMMV. There is nothing additional to “turn on”.

This is the script used by the Shotcut developers:


You’re right (except about me asking for special packages - wait, maybe you’re talking about me asking if it’s already “bundled” with correct dependencies - it is, apparently now, in your standalone)…

While waiting for a response here, I downloaded the standalone because I knew someone was going to ask me for a log…

The whole thing worked out of the box.

Side note: When I added a clip it complained about something like a non-standard frame rate (is h264) then crashed. When reopened, the clip responded fine on the timeline. I didn’t see anything significant in stdout, but would want to re-test (another topic if still an issue, no need to discuss here).

At any rate - this is beyond weird - I have direct and specific memories of the hassle I went through trying to get this to work… Just look at the detail in my opening post.

I had a similar issue with Gimp. While working out my install script for the at-that-time-new Debian 9, I noticed Gimp’s color picker gradient had changed direction. It annoyed me because I go to greyish tones automatically for themes I make more or less by muscular memory. The version of Gimp hadn’t changed in quite some time… So I wrote the developer to ask about the change. He said it’s always been that way (confirmed by 2 devs)… Pretty weird - I’ve been using Gimp and only Gimp for over 10 years (since '06) frequently (2 or more times a week) - and it was never that way. They’ve since changed it in the latest release - to the way I’ve always remembered it yet never existed.

Unless you folks changed the standalone recently to include the correct dependencies - then this is a straight up Mandela Effect… It doesn’t matter how we feel about it, and I didn’t make up the memories I have of my previous install attempts with ShotCut. I simply won’t be convinced otherwise. Knowledge is built on memory, repetition, saturation etc (look it up, it’s in the wiki) - and I know the problems I had, and what I had problems with, while installing ShotCut the last time - or I wouldn’t of made this thread. Welcome to our fluid reality for those Effected (affected, not everyone is for some reason).

Anyway - problem solved I suppose.

Again, thanks to you and the other devs for making a great program accessible to those of us using Linux!

If you are able to reproduce this behavior, please let us know in a new post. We are very interested in improving these kinds of problems.

We have made improvements to the included dependencies in the last 6 months. So that might explain it. Ha ha to the Mandela effect - it just shows that we are all a little crazy. So that might also explain it :slight_smile:

I figured out how you’re quoting!

Yep - can do.

Well then, that would explain it. Based on previous experience with other things, I wasn’t expecting you had.

Ha ha - it’s real. Are you including yourself in the “crazy” pool? I don’t think most folks would consider themselves crazy - but then I don’t suppose actual crazy folks would know the difference either way. You don’t seem crazy to me, so go easy on yourself! :slight_smile:

Back on topic…

Thanks for the clarification on the changes - we can call this one closed!

This topic was automatically closed after 90 days. New replies are no longer allowed.