Crossfade breaks after adding zoom with keyframes

Hi everyone!
I am new to Shotcut - and video editing entirely, truth told. Watched a lot of video tutorials and thought I understood what to do to achieve my design, but apparently not.
I have a series of still images I am using to build a video. Each image has been set to 7 seconds.

I added two images - Image1 and image2 - and dragged image2 over the last two seconds of image1 to make a crossfade. That worked just like I wanted; nice, smooth transition from Image1 to Image2.

Then, I selected image1 and added two keyframes - first at 1 second and the next at the end. I set the end keyframe to 120% zoom, to make a subtle movement inward on the item in the image. Again, looks exactly how I want.

However, now the crossfade doesn’t work right. Image2 fades in on top of Image1, but Image1 does not fade out; it just blinks off at it’s end so that you see it clearly under Image2, until it suddenly disappears.

I tried adding the keyframe zoom to both segments before I dragged them together to make the crossfade, but it does the same thing.

I exported the video to see how it looks, and the problem I see inside Shotcut carries over into the mp4 file.

No idea what I’m doing wrong, and any suggestions would be sincerely appreciated

—A

Ok. So I found the Slideshow Generator since I posted and now have another problem.

The Slideshow works exactly like what I want, so YAY! But when I run the video, some of the images are cut off, before the gentle-zoom…like they’re cropped or already zoomed. They look fine in the thumbnail on the timeline. But the video preview has some images cut off or distorted.

It looks like maybe I need to use images that are all the same size (maybe?). My series has a mix of 360x480, 1280x960, 640x401 etc.

Is that my problem? And, how do I fix it?

Thanks once more in advance for your suggestions.

—A

Ok. So I found another video tutorial which explained about the Aspect Ratio Conversion setting and how it works.

Got it. Looks pretty good!

YAY Shotcut!

—A

BTW, I’d still like to know what I did wrong in my OP. Seems like that should work, even though the Slideshow Generator is much quicker

I may need the long way for some other formats which would intermix stills with video and use different transitions.

Thanks!

—A

If you use on slideshows photos with the exact output ratio or better the exact export pixel size and turn off the sliding zoom shotcut does not create a position, rotate and zoom filter with keyframes for this image in the slideshow.
Be aware a photo that is one pixel shorter or longer than the export pixel settings will trigger the use of the position, rotate and zoom filter with keyframes.
If you cut or extend the size of a element with keyframes you always have to correct the keyframes manually of this element.
darktable is known to export the photos with often incorrect sizes.

I tried to replicate what you explained in your original post:
A 2-second transition between clip 1 and clip 2
And an Size, Position & Rotate filter on clip 1 with a keyframes at 1 second, and another one at the last frame for the zooming effect.

In my attempt, the transition and the zooming work as expected. No blinking.

Did I do something different than you? If so, can your reproduce your way and make a video capture that you could share here on the forum?

I think as long you do not shrink the length before crossfading by cutting or editing the last keyframe still exists in the clip, but if you cut and delete the last keyframe of a clip, than a keyframe with zero position and % size is added to the clip in the end.

Thanks for the input, everybody! Much appreciated.

I’m under a time crunch and have a workable method at the moment.
Soon as the project is done, I will learn how to record my screen and put up how I was doing the zoom/crossfade stuff.

Very interested to understand what I was doing wrong.

—A