Crossfade anomaly


#1

Greetings

working on multiple shots, bringing them together.
Crossfade auto-function when dragging them together

– but the crossfade itself… ?? Why is the actual crossfade like a new section - such that if i make a crossfade then decide to do something else / improve / alter one or other of the clips, i drag a clip to a new track, but the crossfade has become an independant object. Not only does it stay behind, but now I have to ditch it & realign the two tracks all over again.

Surely the individual objects/segments should work like any audio file auto-crossfading in a DAW? Have I missed something?

regards

Adrian K


Change length of transition by moving the 2nd video clip
#2

I find the system works quite well. Because the intersection is a separate object you can apply many different kinds of transition (crossfade is just the default) and even apply filters. I’m not a programmer, but I don’t think you’d have that flexibility if the transition didn’t become an object in it’s own right.


#3

I don’t think you’re missing anything. The clip-overlap crossfade feature is not useful for our workflow either. We create documentary-style videos where the interview video and dialog may have to be rearranged many times before the flow sounds right and hits our length targets. Modifying the independent crossfade objects for every rearrangement is a major slowdown. So we avoid the clip-overlap feature entirely and go back to the traditional two-track NLE experience where the higher track does a fade-in or fade-out to reveal the track below it, and the end result looks like a crossfade. There is a checkbox to “Adjust opacity” on the fade-in and fade-out filters that let you see to the track below it rather than fade to black.

For simple videos, the clip-overlap feature may work fine. And it would also be necessary if you want to specify a transition other than crossfade. But that’s rare for our style of video, so we avoid it. But overall, I think the feature is working as expected. It’s just not what you need.


#4

This is not a bug. It is simply the way it was implemented because it is easier. Should dragging one of the clips drag the clip on the other side of the transition? If so, what if that clip has a transition after it, should that be moved with it as well? Yes to those questions implies multiple selection and grouping functionality, which Shotcut does not have yet. Lack of a feature is not a bug. Perhaps it can be argued that the transition should be automatically removed when you move a clip. However, what if that was accidental? Then, you could not simply move the clip back; you would have to recreate the transition (ignoring the fact that you can Undo because some people forget about it). I did not try to create the most awesome, fully featured timeline implementation before releasing the product. If you pay any attention to Shotcut history, then you realize it is frequently released during active development.


#5

Hi Austin
" go back to the traditional two-track NLE experience where the higher track does a fade-in or fade-out to reveal the track below it"
brilliant - I’ve drawn a blank - where is the ‘adjust opacity’ etc checkbox??

regards

Adrian k


#6

image


#7

Exactly where sauron said. To get to that screen, go to the menu and check that View > Filters is on. Then look for a Filters tab docked somewhere on the screen and you will see a panel that looks like sauron’s screenshot. You can create the “Fade In Video” filter by adding it manually, or by grabbing the fader handle in the upper left or right corner of your clip on the timeline and dragging it for the fade duration you want. The handle will make a sonar-like throbbing animation when the cursor hovers over it.


#8

You can also use the Opacity filter in the video section of the filters, however you can’t currently save presets. Using the Fade in/out and ticking the box is usually the most straightforward way of doing it.