Cropping 4:3 to 16:9?

Hello all,

As I’m experiencing issues (cf my previous post), could anyone explain how do you convert a 4:3 (ie 1440x1080) video to a 16:9 (ie 1280x720) by cutting top and bottom (not stretching)?
Tried cropping, used the 720p preset, all looks perfect on preview, but getting additional black bars cutting even more top and bottom on export. Final video being 16:9 including black bars. :frowning:
Seems like the basics and it’s blocking my whole project as I’m gathering multiple collaborations and want to have them all at the same format.

Many thanks in advance!

On the 4:3 video, remove all current cropping filters. Then add “Rotate and Scale” with a Scale of 133.4% and make sure it’s first in the filter order.

EDIT: Disregard this recommendation. At the time I wrote it, I did not know that “Crop: Source” was evaluated before the automatic scale and padding to fit the timeline. That being the case, “Crop: Source” is a better solution.

Thank you for replying Austin!
I have tried your method but still same result unfortunately.
Maybe if I show what I have on screen it will help ?

original 4:3 image shown in 16:9 project:

Sorry I’m limited to one photo at a time :frowning:

rescaling 133.4%:

Exporting in 1280x720: (same result with preset 720p modes):

Final video: :frowning:

There is already a 1280x720 25 fps preset in Settings > Video Mode > Non-broadcast. Maybe there is something incorrect in your redundant custom preset. If you are changing the resolution or aspect ratio in Export, that is a sign there may be something wrong with Video Mode. With intimate knowledge of Shotcut internals, I struggle to understand how additional cropping is occurring. It does not do that. When things do not match up black padding is rather added. Otherwise, I do not use Rotate and Scale for this purpose.

  1. Start over
  2. Settings > Video Mode > Non-broadcast > HD 720p 25 fps
  3. open the video file
  4. add the Crop: Source filter
  5. click the Center checkbox in the Crop: Source UI
  6. Export, do not click anything in Export except Export File

Thanks for replying once again :slight_smile:
I had tried both custom and preset settings but ended with the same results.
Unfortunately after following the exact steps you have mentionned (new project etc…) still the same issue.
While uploading the original video I had this message:

Maybe that would explain ? (I have some doubts as my main project (compiling all videos), also adds additional black bars on export) :frowning:

Are you sure you’re playing the right file in VLC?
Do you have a file named 720p resizing 2.mp4 ?

From your screenshot from Shotcut:
10 second video

From your screenshot of VLC media player:
13 second video
firefox_2020-08-29_14-05-59 firefox_2020-08-29_14-05-47

Well seen haha, I don’t remember, I shorten the video to 10 to 15 seconds so that exporting takes less time, but in any case all videos exported have the same exact issue. So no solution I reckon? :frowning:

First we need to find the cause to get a solution.
I was able reproduce what you have exported.

To correct the issue of this example, and going along with @shotcut’s instructions above:

If this doesn’t represent what you have, perhaps upload your MLT file for further help.
What are the Source video properties? (Click on the source clip, then Properties)

Or try to reproduce the issue with this image. Feel free to download it and use it.

I do not reproduce it. Project in Shotcut:

and the player

This is how it appears in the preview.

This is how it appears in VLC

Exported frame and opened in GIMP

Source video 1440x1080 5 count (438.6 KB)
Project file 1440x1080 convert to 1280x720 200px crop.mlt (1.9 KB)

Thank you so much for taking the time to help :slight_smile:

So with “centre cropping”, this is what I would like to have on the final video

But this is what I get on export (extra black bars cutting off the image)

With the 200px on top and bottom it cuts too much of the image:

…and curiously I get the same video result as above :confused:

Here is my .mlt file:
720p resizing.mlt (3.9 KB)

I hope it helps…!

This file does not have a crop filter applied, and it does not refer to the video shown in the screenshots above. The Video Mode looks fine.

But this is what I get on export (extra black bars cutting off the image)

Try a different media player. Maybe something is wonky with your VLC configuration. Try in Shotcut. To reduce possible confusion after export job completes successfully, double-click the job to open the result in the Shotcut Source player.

1 Like

:astonished: on the forum it displays correctly! And when importing the cropped video back to the project on Shotcut it seems to be correct! So it would be a VLC thing ? Tried fiddling with the ratio on it (VLC), but still the “Source Video” text stays without the “1440x1080” as it is overcropped. So strange! on Windows Media Player it displays correctly as well!
Did a few additional tests and indeed it’s on VLC only… Thank you so much for your help!

I have a 2nd weird thing happening which is not a problem but still confusing… when uploading our drummer’s video (originally 1920x1440) without any cropping, it appears as such (4:3)

BUT when I’m uploading the guitar video (myself), it’s supposed to be 1440x1080 (4:3 - imported from the camera’s SD card), but displays as 16:9… Any idea why ?

I wrote the previous message without seeing yours :slight_smile:
As you said, it’s indeed VLC…
I normally have the filter applied when I click on the video timeline… (as my previous screenshots show), but it’s not relevant anymore :slight_smile:

Pixels are not always square. That might come as a surprise to you. But maybe you recall anamorphic widescreen DVD movies? These are 720x480 in NTSC, but 720/480 is neither exactly 4:3 or 16:9. A popular camcorder format from the 2000s called HDV uses 1440x1080 for 16:9 HD, and some DSLRs did that too.

That DOES come as a surprise! Just read a bit more on the subjet, thanks for your lights (not sure it translates from French: Merci pour tes lumières :sweat_smile: )
My camera has ONLY 1440x1080 for filming (it’s mainly for pictures), it’s about 10 years old I’d say.
Great info, thank you! And thank you for your help in solving my issue :slight_smile: :+1:

This topic was automatically closed after 90 days. New replies are no longer allowed.