Crop: Rectangle glitch

ok so, hi i’m new here, i was trying to crop an image with the crop rectangle filter, but it keeps giving me the black void and i don’t know how to remove it

any help is appreciated, thanks-

oh right, this only happened after i downloaded the newest version-

Crop-source could also be helpful.

ah, i try to use it but i find it hard to use, so i stick with crop rectangle instead-

A la suite du filtre “Crop: Rectangle” vous avez mis un “Size, position & rotation”, c’est ce qu’il faut faire. Ajustez les paramètre de ce filtre pour agrandir votre image recadrée et la positionner correctement sur l’écran.
Et si vous voulez que votre image recadrée occupe tout l’écran, vous n’avez pas besoin d’utiliser “Crop: Rectangle”.
Seul le filtre “Size, position & rotation” est nécessaire pour agrandir l’image et la repositionner.

After the filter “Crop: Rectangle” you put a “Size, position & rotation”, this is what you have to do. Adjust the parameters of this filter to enlarge your cropped image and position it correctly on the screen.
And if you want your cropped image to occupy the entire screen, you don’t need to use “Crop: Rectangle”.
Only the “Size, Position & Rotation” filter is needed to enlarge the image and reposition it.

image

uhh this happened-

Pouvez-vous expliquer ce que vous avez fait pour obtenir ceci?

Can you explain what you did to get this?

exactly what you told me to do, i put crop rectangle and then i put size position and rotation.

and then i moved the crop rectangle filter a bit since, it wasn’t covering anything, so when i moved the crop filter, it became…this

switching it around gave me this:
image

Apparemment votre personnage fait partie d’une image en mode “paysage”. Vous le recadrez en mode “portrait”. Ce n’est donc pas possible qu’il occupe tout l’écran sans être déformé.
Soit vous souhaitez qu’il conserve son aspect et vous aurez donc des bords noirs, soit vous devez le déformer.

Apparently your character is part of an image in “landscape” mode. You crop it in “portrait” mode. So it is not possible for it to occupy the whole screen without being distorted.
Either you want it to keep its aspect and you will have black borders, or you have to distort it.

Pouvez vous télécharger ici votre image d’origine ?

Can you upload your original image here?

still2
here’s the original image-

OK, so it’s a vertical image.

  • You keep it with its original proportions you get this. Black borders on each side

  • If you enlarge it to remove the black borders you will only be able to display part of the image (head, feet or bust).

  • If you distort it, you display everything, but the appearance is not the same as it was originally.

  • In the first case, if you choose “background color = white” in the filter “Size, rotation poistion” you will get this.

yeah that worked-
image
there used to be a “transparent background” option here

It is still there, but we need to increase a height value in the filter to allow you to scroll to it. In the meantime, you need to increase the height of the Filters panel to access it.

oh wow i didn’t know that- thanks bro!