Crop filter missing in exported video

What is your operating system?
Windows 8.1

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.06 BETA 2 64-bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

  1. Open any project
  2. Turn on proxy (360p)
  3. Apply crop filter on any clip
  4. Export the video in original quality (i.e. with preview scaling off)
  5. The crop is missing

What exactly do you mean when you say it is not working? Please note:

What the Crop-Rectangle filter does is keep everything that is within the rectangle as it is and anything outside the rectangle is set to the “padding color” (which can also contain an alpha-channel (transparency)). It does nothing to the resolution of your video. It will not get rid of black bands at the side of your video or on the top/bottom.

It is not like the “crop” tool of most image editors which cuts everything outside the rectangle and makes the image resolution equal to the rectangle dimensions.

Yes, I know what it does. It does show up as expected in the preview screen as expected, the problem arises only after the video has been exported. It’s as if there’s no filter applied there, the original video is exported.
EDIT : I’m using the Crop:source filter though.

I can’t think what the problem is I’m afraid. I have just done a test with the “Crop: Source” filter and the exported video is as it should be with the filter applied. Maybe someone else has an idea.

It might help if you could post a screenshot of the whole Shotcut window at the point where the filter is applied and the filter highlighted so forum members have a better idea.

I did not reproduce it, but I did get a different result between preview and result because Crop: Source removes pixels from edges of the input video, and it does not know about proxy. So, a value of N is a different percentage of proxy versus source. There is no workaround for that now other than to disable proxy on the clip’s to which you are using Crop: Source.

1 Like

Yes. I had to switch back to manually creating proxies using ffmpeg.