Crop: circle / rectangle crash app (OSX)

Shotcut: 20.02.17
OSX 10.14.6
Mac mini (Late 2014) 8GB

When trying to apply a Crop Filter circle or rectangle, Shotcut crashes immediately.
The filters are not applied when reopening the project.

crop

Sorry to hear that. It works fine for me on my two Macs (macOS 10.14 and 10.15). These two effects use HTML via WebVfx, and maybe there is a problem with that running on your system.

How could I test, if it is running well on my system? Is there something I can check?

Shotcut: 20.02.17
OSX 10.15.3 (19D76)
MacBook Pro (Retina, 15-inch, Mid 2014) 16 GB

I have exactly the same problem.

If by chance I get successful in applying the filter to a clip, then Shotcut crashes immediately. In that case, if I reopen the project, the filter is apparently applied. BUT if I click on the clip to which the filter has been applied OR when playback indicator goes over that clip during playback, then the program crashes and there is no way to remove the filter.
In this case, to recover the project, the only way I found is to open the .mlt file with a text editor (Atom in my case) and manually remove the code referred to that filter.

How can we check if HTML via WebV is doing well and what should we do for fixing it?

Many thanks

With the same version Shotcut: 20.02.17 on OS X Capitan
I do not have Crop: Circle ???

20

All, does it work in a previous version? Perhaps some change related to preview scaling caused a problem I have not yet reproduced. See related issue for how to check WebVfx (any HTML-based filter including Text: HTML, Swirl, Text: 3D, Rutt-Etra-Izer, and Choppy).

Installed version 19.12.31.
Apparently the problem does not occur. Tested all HTML-based filters you mentioned and they were applied without any problems, also on projects created with ver. 20.02.17.

Thank you for the feedback @Francesco_Vidotto. Some change to handle preview scaling whether enabled or not is causing a problem. Now, I can investigate further in this area.

Can someone with this problem please test the unsigned version 20.02.17?

https://github.com/mltframework/shotcut/releases/download/v20.02.17/shotcut-macos-unsigned-200217.dmg

I suspect a problem with entitlements for the new hardened runtime requirement for signed and notarized apps.

Can you please test this new build that is signed with additional hardened runtime entitlements?
https://s3.amazonaws.com/builds.us.meltytech/shotcut-macos-signed-200217.dmg

Since a few versions, Shotcut.app is notarized by Apple. However, in January, Apple increased the requirements for notarization by requiring the hardened runtime to be enabled during code signing. Now, in order to do certain things in your app, you need to enable entitlements. While testing on my Macs, I did not need to add any entitlements! Then, I had a bug report shortly after v20.02 released that it would crash in macOS when trying to open the microphone or webcam. I could not reproduce it, but I gave a newly signed build with entitlements to access audio input and camera, and that fixed it for them. I believe the WebKit HTML runtime that some filters use requires the JIT entitlement. However, even when I do a fresh install of macOS 10.15.3 in a virtual machine, I do not reproduce the problem. Frustrating! I can find nothing about why hardened runtime behaves different from one system to another. Nevertheless, I added some the JIT entitlement plus a couple of others for test.

You are amazing!! I just tested the new version. The circle and rectangle crop work like a charm for me. It is very useful in combination of a partial chroma key. Thank you for your awesome and hard work.

2 Additional minor Remarks
(edited) 1. I tested the app on my desktop for not replacing the Shotcut I have.
I noticed the application has a problem shutting down (the app does not respond after quit).
2. I moved the App to my Application folder, and then I could not open my project any more. The WEBFX files are referred to in the project with an absolute path to the application. Since I moved the application these paths do not exist anymore. The standard dialogue does not allow to find the files inside the application folder (2 more screenshots attached)

57

This is known problem at times with the HTML-based filters for which I not yet found a fix.

The WEBFX files are referred to in the project with an absolute path to the application. Since I moved the application these paths do not exist anymore. The standard dialogue does not allow to find the files inside the application folder

Oh, right, Finder rather hides that .app is a folder. I will try to make a change to automatically repair paths to app-provided WebVfx resources without dialog for the next version.

Thank you for testing! I will replace the download and included these entitlements from now on.

done